Garmin HRM strap will pair with TR but no hr data shows?

I upgraded my iOS yesterday and it seems that the Garmin strap will pair with the phone, but no hr data shows on the TR app. I’ve tried wetting the strap, but to no avail! Any suggestions?

Can’t help you there, but I have the same problem with my smart trainer (a spin bike with a iConsole+ device). Worked perfectly with the previous version of the app. But with the new app I can pair the device with the app, but no watt-data shows. Which results in the fact that I can’t do any workouts anymore. Please give me the old app back. Wasted so much time the past few days with countles attempts to fix this and without any training :frowning:

There is nothing worse than wasting time solving tech issues. And your issue is more problematic, because no hr data is minor than the trainer not pairing. Hope the computer jockeys at TR read these threads and are working on a solution.

They’re even more likely to solve the problem if you email them at support@trainerroad.com and tell them what’s up…

2 Likes

Tried that. Waiting for further assistance after the first reaction consisted of nothing more than the usual answers, like “try installing the app again” and “make sure your trainer isn’t paired with another device”.

1 Like

Those are definitely early-stage troubleshooting steps, stick with it though and the team will run through some more processes to help sort you out!

Until then, best to report in the corresponding bug-related post for new mobile releases.

1 Like

Hi, I’m experiencing the same issues. Did some Google work and seams widespread with the garmin dual strap. For me I can find it with trainerroad and strava app but hr stays at - -. Edge device and previous phone no issues over ant+.
Even did a reset of the hr monitor (remove battery and reverse connect apparently does this) but no avail.
Complete reset of the phone I use is no option.

Any other ideas?

Are you connecting your HR strap to another device like a garmin watch or computer? I have a wahoo HR strap. When I want to use it, I turn my garmin 935 off, then connect the HR strap to Trainerroad. Then I turn on my Garmin, and it syncs to both. It seems that the TR app wants exclusivity initially to connect. If it is connected to my Garmin watch first, TR app doesn’t pick it up.

I have a similar issue if I want to connect to a bluetooth speaker during a workout. It crashes the app. I find that if I connect to the Bluetooth speaker before starting the app, it doesn’t crash.

This was my experience with always having the latest app version, on an iPhone SE with always updated IOS

Might not be applicable, but worth trying

Nope, no other connection in use. No other connections made at all other than trial with strava app with same issue.

Have tried resetting everything, including the strap. I use the strap with my garmin edge but that goes through ant+.
Even after 24h shut off no connection with HR.

I have the exact same problem with my Bryton HR montior, it pairs but no data shows during the ride. I can see the numbers after the ride though. This never was a problem and started happening maybe 1 month ago?

I have the same issue with the Garmin Dual. Somehow it works now. What I did was letting the HR strap connect to the phone. Then I went to BT from the phone and kicked the HR from the phone again. After this it worked in TR. I don’t think its a TR problem as I experienced the same issue with the Xert app. But everytime the message to pair comes up on the phone, I cancel it. I tried a few times to pair , but this broke it again.

An update on this: we’ve been investigating an issue with Garmin’s newer devices that have a “dual pairing” function. From our understanding, some of their newer sensors can broadcast to two apps/head units over Bluetooth simultaneously. It seems these devices can get in a state where they report null (–) values. This was happening on our older apps and it appears to be happening in the new version as well.

Based on other athletes experiencing this issue on other 3rd party apps, we don’t think this is an issue with TrainerRoad.
The support team (support@trainerroad.com) is still a great place to start with troubleshooting, but a good preliminary step is to double-check that your HR device isn’t paired to any other apps/head units (even though it’s supposed to be able to broadcast to 2). It could be worth physically moving to an area where other potential pairings would be impossible, and could be worth testing the TR app on another device too.

I’ve tried to connect while driving (passenger offcourse) so there is no chance of local bt interference but still no luck.

Battery? Worth a check early in the troubleshooting so you don’t beat your head against a wall later on.

I have the same issue. Although mine will start off broadcasting the HR but randomly drop out and not return.
Changed batteries, forgotten and repaired. Checked with my watch and it still shows HR fine. (Don’t use watch when on turbo though)

Had the same issue. During the workout it showed - as HR but recorded everything. Just had to switch on HR in the settings of TR ,

I had the same issue with a Dual Garmin strap and Android. Connected but no heart rate shown.

I bought a no name HR strap and everything was fine.

Interesting, I don’t have that option though. Android app?