Ipad: after TR update no HR?

When I opened TR on my iPad (IOS 14.4.1) the app updated itself and I had to re-add all three devices (Tacx, Vector3 pedals, Garmin Dual HR strap).

Now the funny thing is that HR stays at – even though it has full connection bars, with battery showing 85%. And the strap is working ok as it does show my HR on the Garmin Edge (over ANT+, the ipad is obviously using BT).

Anyone else seen this behaviour? Any fixes? I tried a complete shutdown of the ipad and restart, and also to “forget” the HR strap then adding it again, but it keeps showing – for HR.

My previous TR use. was last Wednesday, and it has been working fine with these three devices since forever.

1 Like

Please reach out to the team at support@trainerroad.com. Device troubleshooting and dropout mitigation can vary greatly depending upon your device versions, firmware, specific settings, etc. They’ll take a closer look and sort you out. Sorry for the trouble!

Ivy’s recommendation to reach out to our support staff is great and I still think it’s going to be your best bet assuming you aren’t able to get this resolved.

I just wanted to chime in here and comment that there are some fairly well documented issues with the HRM Dual and its ability to transmit data over Bluetooth when paired to multiple devices or applications.

Here is a thread from the Garmin forums, for example, and here is another from the Zwift forum.

What I would immediately suggest is going through your other applications, your system settings, etc. and ensure that the HRM Dual is not paired anywhere else. Hopefully this may get things working for you. If not, our dedicated support team should be able to help further. :slight_smile:

Sometimes, at the very beginning of a workout TR/my iPad doesn’t display a reading form my HR Monitor (Garmin).

I simply detach the monitor from the strap, rotate it 180 degrees and reattach. This effectively ‘shorts’ the connection. Takes about 2-3 seconds and TR/iPad then connects to the monitor. I then return the monitor to the correct position.

This has worked 100% of the time for me.

Thanks for the suggestions! Didn’t make a difference unfortunately :slightly_frowning_face:

It does seem to be limited to the iPad. A simple HR monitor app I just installed also shows no pulse, only battery level. Whereas when I installed TR on a laptop and my iPhone they did display my pulse just fine. Weird…

I had a similar issue with the iPad and the Garmin Dual HRM. It would connect but would show only – as HR. Other devices were showing HR from strap just fine.

In the end I got it working again with iPad after a full factory reset. Unfortunately, restoring from a previous backup was not enough. Maybe if you have a backup from a time when it was working.

My iPad also did an update and while I’m not having issues with the heart rate monitor, I have experienced other issues. I also had to re-pair all devices (Wahoo Kickr V5, HR monitor).

  1. When I load a workout it used to say pedal to begin workout, I would then hop on the trainer and after 3 seconds turning the pedals the workout would begin. Well, after the update, It now also said pedal to begin workout but then it just stared my workout before I even got on the bike. Not so good!

  2. My cadence was fluctuating between 90 then would go to 255?? then back to 90 and this repeated the entire workout. Annoying! I tried to unpair and re-pair the Kickr with no luck and then it said “no device connected for Power” even though it said the Kickr was paired. so had to re-pair again only to get the fluctuating cadence again.

Took me like 45 min just to try and get started. Really hope they can get an update to fix all the glitches soon. Was working flawlessly previous to this update.

I also miss having the current time in the upper left corner. Now it just shows what time the workout will be complete.

I’m having the same problem. After the upgrade. No more HR. My HR shows on my Garmin, but not in the app on my IPhone.

Removing the app and reinstalling (suggested by TR as a possible solution to the app crashing in a specific workout) didn’t help either.

Interestingly, I salvaged an old Wahoo Tickr (the strap had broken, a known weakness) and that one works fine in TR on iPad.

Yesterday evening i had similar problems. I could connect the Wahoo Tickr and Wahoo speed sensors via bluetooth with my phone, but when opening the TR app, it would not find them. After 20 minutes finally the speed sensor did connect so i could do the workout, but HR never connected.

Same issue with same strap and android app on new s21+, looking for a solution too!