TR updated itself, no longer runs with Zwift

Hi there,

Apologies if this has been asked. Haven’t used TR for a while, but jumped in yesterday to discover it has new interface and also, annoyingly, not working with Zwift anymore.
I used to be able to do TR workouts while passively riding Zwift. TR is controlling trainer via ANT+ and Zwift reads only via BT + Companion.

What happens is, once I launch TR, it cuts Zwift readings and it no longer receives any data. There was an option to pass-through in TR, but it is gone now.

I can run Zwift and TR together on IOS though, but it’s not very convenient.

Thanks for the help!

I used TR and Zwift this afternoon with no issues.


This probably doesn’t help but the combo of both TR & Z worked fine for me today on Win 10 when using 2 Ant + dongles.

I have noticed that if you don’t hit OK in Z at the device pairing stage, the controllable pairing will be reestablished if left to the end of the OK countdown


Thanks guys, I’ll take a look tonight again.

TR had an odd behaviour as well. When I tried minimizing it, few times, even restarting, it would go to the bottom of the screen as normal, but there was an inactive “always on top” window remaining in the middle of the screen, that would not respond to anything, and it was blocking view of Zwift or any other app. Feels a little raw, this update.

1 Like

Make sure to try a shutdown and restart if you haven’t.

I’m able to run both via 2 ANT+ dongles and also tested with 1 ANT+ and 1 BLE dongle on my Windows setup. Worked fine in both methods.


My guess is that the new TR update, which now supports Bluetooth, is grabbing the Bluetooth connection from zwift and thus causing your problems. Turning off Bluetooth within TR might fix things (tbh don’t know if you can fully disable it, haven’t played with that myself)


When TR updated their device connection screen I switched Zwift over to ANT+. No issues.

1 Like

Was going to start my own thread, but found this one to be relevant.

I have a brand new Apple TV 4K along with a one year old MacBook pro with ANT+ dongle. I can get either program to work independently, but run into issues while trying to run at the same time. I want TrainerRoad to control in ERG mode, and have Zwift simply read power and cadence.

I load up Zwift on Apple TV and connect via Bluetooth, only select power and cadence, and DON’T select Controllable. All is good there. I load TrainerRoad on the Mac, it recognizes the trainer via ANT+ (tried turning off Bluetooth as well). All seems good. I start up a workout in TR and Zwift is reading fine, I get data in TR but it’s not controlling the resistance. It feels like I’m basically on a flat road. I know Zwift isn’t controlling it either, as I’ve gone up hills in game with no change in the trainer. I’ve also tried the reverse process with no luck (load TR via ANT+ first, then load Zwift via Bluetooth last).

It’s like the trainer is confused on what program is controlling it, so it just does nothing? It’s a new Cycleops H2. Tried the same process with my iPhone and got the same result. Am I missing something here? Would like to use the Apple TV Zwift app if possible, to avoid running both programs on my Laptop. Any advice would be appreciated.

1 Like

First thing to do is go to the device pairing screen in both apps and confirm that each is still paired via the com protocol (BLE/ANT+) and reconfirm that Zwift is not paired under “Controlled”. I’ve had Z re-grab that setting on occasion.

Then in TR, make sure you have ERG mode selected in the device screen.

1 Like

I think I’ve tried the process you outlined. I’ll give it another go when I get home this evening.

1 Like

Still having issues with this combo. I stumbled into this reply on a similar thread.

Seems like an issue for some users. Zwift is basically defaulting to select controllable, and even when you unselect it, the programs still fight each other. Looks like I’ll try the quick click past the pairing screen to get it to work again.


Apple TV Zwift with TrainerRoad at the same time on a Mac. Zwift on Bluetooth and TR on ANT+ dongle.

Ok, so I did some testing yesterday. Still not a 100% solution, but seems to be working for the most part.

It seems that the Apple TV Bluetooth and Zwift like to auto-connect when a trainer is detected. Here’s what I did to work around that:

  1. Ensure trainer is in sleep mode, or better yet unplug it.

  2. Boot up Apple TV without the trainer on and launch Zwift.

  3. Log in and load up your world/ride without connecting anything.

  4. Turn on trainer and load up TrainerRoad. Connect via ANT+. Make sure trainer is reading and all other ANT+ accessories are connected.

  5. Don’t know if this matters, but I went ahead and loaded up a TR workout and started it.

  6. Go into Zwift menu and connect to trainer. It STILL tried to auto connect to the controllable, but I just quickly unchecked it.

  7. Back out of settings and start pedaling. You should now be moving and seeing data in Zwift. TR should be reading as well and controlling your resistance.

This worked well for most of the ride, a few times my ANT+ connection dropped out from TR and I had to pause the ride and reconnect. Not sure if it’s something with my Mac/ANT+ dongle or the interference with Zwift coming in and out. Either way, kind of annoying. I wish there was an option in Zwift to NOT connect automatically and instead manually pick everything.

Here’s a little video from the end of my ride, you can see it pause and lose data quite a few times.


This worked well for most of the ride, a few times my ANT+ connection dropped out from TR and I had to pause the ride and reconnect. Not sure if it’s something with my Mac/ANT+ dongle

I’m having the same issues after the forced update Mac version 2019.30.0.64 to 2019.33.0.66. With the .64 version, everything was working fine for me. Minor dropouts of 1 second, but the software automatically reconnected to the Tacx Neo. With the .66 version, it won’t reconnect after a dropout. I have to quit the app and restart it, before it reconnects. And the only software running on this iMac is TrainerRoad.

My contact to support was useless, because they’re always saying “it’s a wireless interference problem”, or “something else on this Mac is grabbing the ANT+ connection”.
Version .64 is running without problem, so how can it be an interference problem and my HR sensor is still sending signals to the software, so nothing else is grabbing the ANT+ connection.

Now I’m using version .64 out of the DMG-installation-file and can do my workouts without any software issues. Maybe support will eventually take this problem seriously.

1 Like

Good to know, I’ll bring it up as well. Give it some more exposure.

I’ve been running TR and Zwift concurrently for years, with Zwift on a Windows 10 laptop with an ANT+ dongle, and TR running on my iPhone via Bluetooth. For the first time today, the connection to Zwift dropped numerous times and despite restarting Zwift several times, it wouldn’t run concurrently anymore. This is after installing the latest Zwift update.

1 Like

No problems running TR & Zwift here, ANT+ is the communication protocol that I use.

I’m not a Zwift subscriber but used to be and previously I’ve run Zwift and TrainerRoad on the same MacBook using Bluetooth in one app and ant+ in the other. Never had a problem but tonight I thought I’d use my free 25km Zwift allowance to try the new Yorkshire course but just couldn’t get it working. I’d start TrainerRoad first and let Kickr connect as always via ANT+ and then start Zwift and connect via Bluetooth, removing controllable power source. As soon as I did this and tried to start my workout TrainerRoad reported no devices could be found.
I don’t know if TrainerRoad, Zwift, or both have updated apps but what used to work now doesn’t.

I’m running TR on my iPhone and Zwift on the iPad. TR controls ERG mode on the Wahoo Core. Set Zwift on the iPad to just read power from the Wahoo Core, but not control. Works fine so far…fingers crossed.

1 Like

Braq, are they both on bluetooth?

So do you set up TR on the phone, then when everything is connected start up Zwift on the Ipad? Do you then just select power or do you have to de-select everything else?

Does Zwift try to override TR’s control?

Everything on Bluetooth. As long as you deselect control on zwift it should work. Or, it does for me.