TrainerRoad whilst zwifting change


I’ve long used TrainerRoad whilst on Zwift by my wahoo kickr, cadence and heart rate broadcasting 2 Bluetooth signals (I think). TrainerRoad controls power and reads heart and cadence, whilst zwift simply reads the power and can’t control the kickr.

Recently this has stopped working, Andy body else use this method? Anyone notice any recent changes?

Oh and I do this on a Mac book laptop


Might help to have an active screenshot of the Device pairing screens for both Z & TR, so we can see if there is anything obvious in either one.

Will do, I’m on just on TR now so will do it later. But I usually connect everything to TR first, then in the zwift device connection screen pair everything there except “control”. Now nothing shows in any box as if it’s suddenly stopped sharing Bluetooth connections

I can pick up all the sensors on my garmin watch whilst using TR so it must be something to do with the Mac/TR/Zwift relationship

Depending on exactly which version of Kickr you have, some allow up to 3 simultaneous BLE connections. Not sure on the HR?

When in doubt, close any and all devices other than those of interest. If you used your phone or other devices at some point, they might still be holding a channel open and effectively preventing future connections.

Power cycle the trainer and make sure nothing other than what you want is connecting to the trainer.

I’ve run into a similar issue. I used to start TR, then Zwift, and everything was good. Now I have to start Zwift first, let it grab everything, then deselect the controllable trainer. While still on that screen in zwift, I launch TR and it grabs the controllable trainer and both are happy to share the cadence and HRM sensors.

If I launch TR first, it grabs everything and zwift gets nothing.

I’m on an OG Tacx Neo, using Bluetooth, but I think the principle is the same. I’m on an M1 MacBook Pro.


1 Like

I ran TR (laptop) and Zwift (iPad) today with gen2 Kickr, the same way you mentioned and had no problems. Did BTLE get turned off on your Zwift device?

It’s still broadcasting blue tooth signal as my garmin watch picks up all the devices when I search for available devices whilst using TR.

I’ll try the suggestion above - doing zwift first - and see if that makes a difference. Like I say, this all used to work and suddenly stopped, as if there had been a sw change on either the MacBook, TR or zwift

Nothing works so I presume either the macOS, trainerroad or zwift sw has changed to prohibit sharing between apps, or one of them or a combination of all of them because the wahoo devices are still broadcasting as my watch can pick them up but zwift or Tr can’t when using one of them. No big loss

Looks like it’s time for the TR support folks to chime in.

I rode Zwift and TR this morning - worked as usual. However, I saw that there was an update to TR that didn’t install until after I was done. Can’t try again until Thursday.

Anyway, I always connect Zwift first using Bluetooth and TR second via Ant+.

1 Like

Hi, I suppose it would work if over ant+ but I use just Bluetooth and it used to work so something has changed.

It’s not a big loss anyway but annoying it no longer works for me

If it helps, I always connect Zwift first using ANT+ and TR second via Bluetooth, so very similar to @rkoswald. A while back I was inadvertently running both off ANT+, but I got the odd drop out. Split up, I don’t get that. But, really when it comes to connectivity sometimes it’s more good luck and good management I find.


Are you certain that you haven’t got a 3rd device snatching one of the two broadcast bluetooth channels only leaving one for zwift/TR to fight over?

1 Like

Yea, because I can use another device, my watch, to search for sensors and it finds them. So the conflict is within the MacBook environment

I must admit that I do my dual zwift/TR stuff with one of them on ant+ so not fully sure about the limitations of Bluetooth.

But my thoughts are that if you also have your watch connected then that is using up one of the two channels. Not sure if you you need both channels free to connect to two different programs on the same device?

If that is not it and something has changed then my money would be on zwift, there have been some high profile cases of people cheating on zwift using devices that intercept Bluetooth signals and re-broadcast - they may have changed something so that zwift hogs the signal - just speculation - but don’t see my TR would have changed anything.

I haven’t done it in a while, but I also used to do it with one n Bluetooth and the other on Ant+

Yea it used to work just from Bluetooth. My watch isn’t connected but if I search for Bluetooth devices from the watch it can see the wahoo devices to potentially connect to as they broadcast 2 Bluetooth signals. Hence knowing the conflict is on the laptop.

As I say this all used to work but something has changed to stop it.

Haven’t done it for a long while, but I was also TR with Ant+ (Samsung Mobile) and then Zwift Bluetooth (apple TV).

1 Like

I’m able to use TR and Zwift at the same time. I’m using a Kickr v5 via direct connect ethernet, Tickr HRM, MacBook Pro, and ANT+ dongle. TR connects via BT to the Kickr & Tickr. Zwift goes through BT for Kickr and ANT+ for the Tickr.

1 Like

I’ve been experiencing something different in the TR app lately that might be related. I have a smart trainer + powermeter, and typically use erg mode + power match. Normally I use TR on an iPad, but also have the app on my phone. I often open the phone app to see what I have scheduled and then later on do the workout on the ipad. I try to remember to close the TR app on my phone before heading to the pain cave, but usually forget.

Until this week, if I forgot to close TR on my phone, sometimes my trainer and PM would connect to my phone instead of the ipad, which is totally expected. I’d notice that the ipad had no devices connected and fix it by closing TR on my phone. Then my trainer and PM would connect to the ipad.

In the last week, my ipad always shows that it’s connected to the trainer and PM, but if I start a workout on the ipad and TR is also open on my phone, ERG mode doesn’t work. If I then close the app on my phone, and restart the workout on the ipad, all works as expected.

I wondered if it was a change on the apple side or the TR side. Either way it’s kind of expected, but the different behavior compared to usual threw me off.