RESOLVED - Mac Mini, Monterey, Bluetooth refusing to enable

So this is new. I have a Tacx Neo Smart bike, latest firmware, and a Mac Mini with Monterey, all the latest updates, and the latest version of TR.

What happens is just bizarre. In the pairing ‘menu’, Bluetooth is ‘off’ and goes to a ‘prohibited circle’ when I try to select it, and ANT+ is the only connection protocol that is on. The connection was dropping like crazy, and I had to start over a few times. Found out the spouse of the house was using the microwave. So I tried to enable Bluetooth. I rebooted, I disconnected all the sensors (and had no connectivity at all) and looked for updates, and security settings, and nothing changed: No Bluetooth. I gave the wife a stern look about using the microwave, and got less than a sympathetic response.

It took me over a half hour, and Bluetooth Would Not Enable.

Does TR use a config file that might have been corrupted? Is there some other reason why Bluetooth just stopped working? It did work months ago…

Mac Mini with a built-in Broadcom 4364 chipset and a BlueGiga USB dongle.

Again, the system doesn’t even enable Bluetooth with the dongle disconnected.

I followed the support doc, and nothing changed. (This comes after FulGaz won’t read the cadence from that bike properly. Weird…)

Any ideas? How can I get to TR support?

Thanks…

2 Likes

https://support.trainerroad.com/

though this makes me sad:

Sorry, we were unable to generate a preview for this web page, because the following oEmbed / OpenGraph tags could not be found: description, image

If only I knew how to open a support ticket…

Unfortunately none of their Mac suggestions worked. sigh

For the record: Zwift works fine. FulGaz will show everything but cadence correctly, either one will interchangeably use either Bluetooth or ANT+. It seems to be a TR issue, and quite an issue too…

This is why it says:

Can’t find what you’re looking for? Submit a request with our Support Team.

Only one app can use Bluetooth at a time So if FulGaz is running and it has bluetooth TR won’t have access to bluetooth. Ant allows one app per ant stick. So if one app is using ant you just need another ant stick for the second app

I’m not that noobish. I use the same setup with multiple apps, and TrainerRoad is the one that can’t enable Bluetooth for some reason. I can see it possibly being a dongle issue, which is why I discoed the dongle, but even the built-in Bluetooth won’t work.

PLUS this isn’t a case of Bluetooth working and not seeing a device, it’s Bluetooth not working At All, and I’m kinda stumped.

And, FTR, FulGaz is kinda stumped on the cadence issue. They say they ‘don’t have a Neo bike to test with’, so are less than helpful, so far. I would doubt that this TR issue is a dongle issue, but could be a driver or some other subtle thing blowing up behind the curtain. Meanwhile the Mini connects to everything Bluetooth I have still. I even deleted devices from its list and that didn’t change anything. Something is broken in TR, or there is a battle royal in software that is keeping it from working.

The reason I mentioned Monterey in the title is I’m hoping if it’s a specific issue with Monterey, someone might catch it.

It’s Bluetooth after all. It’s not voodoo magic or esoteric unsupported dark magic.

Not sure if support suggested this, but its a technique I’ve used with TR Beta and any app that is having problems.

Run this command from your home directory:

find . -iname "*trainerroad*"

(ignore color coding that the forum inserted)

which on my Mac running Monterey gives me:

  • a list of directories under ~/Library/Application Support/ to remove
  • some preference files under ~/Library/Preferences/ to remove

Apologies if that is too technical, that’s what I’ve been doing for 35+ years :joy: on Unix based systems. Old habits die hard.

You could open up Finder and navigate to Library > Application Support or Library > Preferences.

I updated my Mac Book Air OS to Monterey last night.

Used it with my Wattbike Atom this evening with the TR App and for the first time ever it wouldn’t connect via Bluetooth to either my HR monitor or my Wattbike.

I think there maybe something going on between the Monterey OS and the TR App that is glitching.

I tried the usual ‘switch it off and back on again’ approach to both the App (which applied an update) and also the Mac Book and the Wattbike; but to no avail.

I worked around it eventually.

The solution was to open the Bluetooth options box (right click) on the Mac Book and search for devices.

This then prompted the TR App to all of a sudden declare it has ‘found’ my HR strap and Wattbike.

Hope this helps anyone else facing same / similar Monterey OS issues.

:+1:t2::smiley:

I’m running Catalina and just dialogued with TR support re: upgrading to Big Sur. The upgrade process sounds smooth (and much better than my Mohave → Catalina experience). I’ve checked with WKO5 and it seems that they support Catalina and now Monterey as well. So questions for you:

  • Are your running TR, WC, and WKO5 on Monterey?
  • Was the the upgrade process smooth?
  • Is all running smoothly now? [or did you need to code some workarounds?]

Where? In TR?

I guess I’m lucky, but I have never had an issue upgrading the mac. Except for those 16-bit apps that couldn’t be run any longer. I’ve had more problems upgrading Windows than the mac.

I just installed on my other mac, and it worked fine. I’ll try uninstalling and reinstalling TR and see what happens. I should have tried that earlier. DOH!

I should have been more clear: the challenge I had was not with the TR app, but with WC (it is/was an old 32 bit app and didn’t run transparently on 64 bit OS machines.) Support instructions didn’t work for me, but they walked me through the process successfully.

macOS Monterey on my MacBook Pro 2016 (MacIntel):

  • no issues with latest WKO5 which was released early September 2021
  • annoying issue with WorkoutCreator and several workarounds listed here: Workout creator broken on Mac with M1 chip and again, you should make sure and have the latest Harman Air SDK installed
  • didn’t try using TR app on Mac to control the trainer (it worked as a pure viewer)
1 Like

No, on the actual Mac Book itself.
The Bluetooth icon on the very top of the screen. Right click and it pops up.
:+1:t2:

Well, the plot thickens…

Uninstalled TR, rebooted, reinstalled TR, and…

STILL no Bluetooth with TR!

I Zwifted this morning, and ran the log through Zwift analyzer and it reported no connections through ANT+, all devices/sensors connected with Bluetooth with no drops, no fumbles, a solid Bluetooth connection.

So, TR just doesn’t want to connect via BT at all…

AND!!!

The Bluetooth widget on the Mac Mini actually SHOWS the bike, and my HRM strap, but TR will not open the BT channel. Now having uninstalled and reinstalled, it isn’t looking good for TR.

Really sorry to hear you’re still having issues.

Maybe try this if not done already:

  • open up a workout in the TR App
  • click begin workout

The message will flag no device’s connected

  • click on the box that opens up the devices page
  • whilst the App is now on that page and actively looking for devices, do the right click of the Mac Bluetooth devices icon described previously
  • click on the show available devices

Maybe than this will trigger the App to recognise the trainer and HRM concurrently?

Good luck :crossed_fingers:t2:

Settings->Security & Privacy->Privacy Tab->Bluetooth

click “Click the lock to make changes” and then in the right most panel, enable TrainerRoad.app

BT is (I believe) locked down due to the security issues, with BT, a number of years ago.

There should have been a panel/dialog from TrainerRoad asking for BT permissions, if this is the problem.

Edit: “click the lock…” is not required for this, can just toggle the app checkmark.

1 Like