Mac Laptop Bluetooth not finding NEO, HR, PM

This is super annoying.
Mac laptop was working fine until recently. I haven’t used TR for a few months.

When I went connect recently it would only connect using ANT+. Not sure why.

BT is def enabled. I deleted the app, and reinstalled it. It is ENABLED in TR, and Mac.

The devices all connect using my phone… but not using the laptop!! BT is def working… because it finds my Airpods etc… so frustrating.

Any help would be appreciated.

1 Like

When trying to connect to the desktop, have you attempted to turn BT off on your phone? Many BT items in the cycling space can only maintain one active BT connection and if you’re paired with your phone sometimes that interferes with desktop.

I had this problem. I contacted support and they solved it by changing something from their end.

1 Like

Oh wow… thanks!!

Oh, should do it also, then. As I have the exact same problem since a while.

Still having same issue… not fixed.

I even tried a second mac Laptop.

Not sure what the fix is going to be.

Are you on the beta or production version? If the beta, are you on the most recent version? A version of the beta got released that killed Bluetooth, but TR released an update the next day that fixed the problem.

If you are on the production version, please reach out to TR support directly