Bluetooth does not work with TR on MacOS (Ventura)

Anyone have bluetooth for TR on mac (latest version) break in the last few months? I was happily using TR on my Macbook pro 14 M1 for a month or so, and suddenly it could not detect my Tacx Neo, Wahoo HRM and Garmin vector pedals even when Zwift on the same computer works just fine.

I’ve also tested with Zwift (and nothing else, no head unit, etc.) closed and just TR open. Still nothing.

All 3 devices still work with zwift on my macbook pro 14, so bluetooth certainly works. Bluetooth is also shown to be on on TR but it just shows as no devices detected. I reinstalled the latest version again but it’s still the same so now have no choice but to ride paired to my phone for TR and the laptop for Zwift.

Here’s what it looks like when trying to connect: TrainerRoad Bluetooth Issue · CleanShot Cloud

Reached out to support but they said there’s nothing they can do (besides asking my to uninstall and reinstall), and to just ride with the phone. I tried using a ANT+ receiver and it kind of works, but keeps dropping off every minute so that’s also not an option.

Hey @yansim!

This shouldn’t be the case with the latest versions of the app as of last week. I’m going to look into this for you and I’ll get back to you when I have more info.

Hey @yansim,

Thanks for that screen recording. That indicates that Bluetooth is displayed as on in the TrainerRoad app but won’t connect to your Bluetooth devices. Based on that, here is what I suggest you do:

While we are troubleshooting this issue, can you completely uninstall any other fitness app, including Zwift? Fear not, this will be temporary while we get to the root of the issue.

Once we have solved the issue, we can make running Zwift and TrainerRoad simultaenously, work. I will send you some info on how to do that below. However, while we are troubleshooting this issue, can you completely uninstall any other fitness app, including Zwift? Again, this is just temporary while we get to the root of the issue.

Can you please ensure that you unpair all of your devices from your laoptops’ Bluetooth Settings. We will want to make sure that it is only paired through the TrainerRoad app on your laptop. Bluetooth devices can only pair to one receiver at a time. Your laptop, and the TrainerRoad app installed on your laptop, are two separate devices .

Once we have solved the issue, we can start re-introducing apps and devices to see how much your training environment can handle.

Some other things I’f like you to try:

Try fully restarting the computer if we haven’t restarted for a while - If we usually keep the computer on “Sleep” mode, let’s have you try fully shutting down and restarting the computer. This way, we’re making sure that no errors are happening due to the device being on for a long time.

Let’s have you close out of any other apps running in the background - It looks like you have lots of apps open at once. Closing those out will make for a better experience.

Let’s have you try resetting the SMC on your Mac - This is a special fix which will refresh the hardware modules on your Mac (this won’t clear any data). Apple has steps for how to do this Here [click].

Let’s have you try toggling Airplane Mode - In a few cases, we’ve found athletes were able to connect their devices after toggling Airplane Mode. Let’s give this a try, and see if it works.

If you could *turn off your phone * and any other devices you are not using, while using the TrainerRoad app on your laptop, that would be helpful.

Finally, try a ride with your Wi-Fi router unplugged. Wi-Fi signals run on the same channel as your devices send signals out on and the interaction between the two signals can cause issues. If the ride with your router unplugged is better, you can change the channel your router sends out signals on. Here’s how: How to find the best Wifi Channel for your Router on any Operating System.

I appreciate this sounds like a lot to eliminate, but as I mentioned earlier, these are not permanent changes. They will simply help us figure out where the issue lies, and determine how much interference your specific training environment can handle.

When you do eventually re-introduce Zwift, I suggest you follow these steps for running TrainerRoad and Zwift simultaneously.

Let me know how that goes! If you have any questions for me, please just shoot them this way!

Thanks for the response Sarah! I did try all these steps before to no avail, but tried again today and it seems like it might be working again. Could be that it was fixed in the last version. Thank you! I’ll post here if there are any other issues.

Same issue here with a Powertap P1 pedal.
I can’t make it work after updating to Ventura.

Also tried the steps above and did not help.

Triple check you are on the latest version of the TR app. If that still doesn’t work, try the beta.

The latest beta is working for me on a M1 Mac mini running Ventura

1 Like

Hey the update actually made the trick…

The issue was that the app did not update for some reason some adblocker blocked the download…


1 Like

You are welcome - it sounded like the issue I had last week, so thought you might not be on the fixed version

Great stuff, guys! Thanks for helping out, @AlphaDogCycling!

If anyone is still running into this issue, make sure you are on the latest version of the app.

Updates should happen automatically when you re-open the app after it has been closed. But if you want to be sure that you are on the latest version of the app, you can uninstall the app and grab a fresh download from our website here: Download.