Keeping TR running in background (Android)

So during a workout I am running TR app and Spotify at the same time on my Android phone, but I don’t need to look at the TR app because my workout profile is also displayed on my PC laptop in front of me - running Golden Cheetah in Train mode. Running TR on the phone allows redundancy in recording and send a nice TR graphic to Strava afterwards. So ideally I would like to keep TR running in the background and have Spotify in the foreground switching music as I like. The problem is TR stops the workout in the background.

Does anyone know how to keep the workout going?

Thanks

LtS

2 Likes

[resuscitating topic since it never got a reply and the problem seems to be worse in the updated app]

The new, updated Android app (public release) will end(!) the workout when going to other Android apps, even for just a minute. The previous version didn’t do this and nothing else has changed on the phone (Pixel 3).

Is anyone else seeing this?

Hey! Sorry for the trouble. You’ll definitely want to reach out to support@trainerroad.com for assistance. For future issues, we are using these threads for reports on the new apps:

New Android Release Issues / Bug Reports

New iOS Release Issues / Bug Reports

1 Like

Thanks! Support ticket submitted.

1 Like

If you run PC, why not use TR on that? I do, and I get a nice graph on Strava when it uploads. Or have I missed something?

/JB

1 Like

My wife and I run TR on our phones because we have a nice big-screen TV and audio setup for entertainment during workouts. So since we already have a Blu-ray player, Xbox One, and Chromecast w/Google TV hooked up, there’s really no reason (nor room) to add a computer to the mix. Not to mention, computers aren’t optimized to be used as a 10-foot-interface.

Plus, it’s not like running TR on phones is an uncommon scenario. TR wouldn’t have developed their mobile apps if no one used them. We just want to be able to switch to other apps during a workout (for example, quickly respond to a call or text), like we were able to before the latest update.

(note that it was also a problem when using an ANT+ dongle prior to this update, but switching to all Bluetooth sensors, helped avoid it)

I’m still experiencing this problem. Is there any solution/workaround for this issue?

A couple things that seemed to help:

  1. Force stop any apps you don’t need running before you start your TrainerRoad session.

  2. Make sure that TrainerRoad is not optimizing battery. In Android 11 you can do this in SettingsApps & notificationsAdvancedSpecial app accessBattery optimization › show All apps. Find TrainerRoad and change its setting to Don’t optimize.

But to be safe, my wife and I ended up using our previous phones for TrainerRoad so we can keep our primary phones free. One side benefit of this approach is preserving our main phone’s battery when we have a long TR workout scheduled.

Obviously, not an option if you don’t have a spare phone, but thought it was worth mentioning.

2 Likes

Thanks for your hints. Disabling battery optimization and closing all apps maybe helped a little but it did not resolve the issue.
Unfortunately a seccond device currently seems to be the only practical option.

1 Like

Bummer.

If you happen to use an ANT+ stick/dongle, you could also try setting the three ANT+ services required by it, to Don’t optimize as well.

Pity this is the only solution. I tried running TR in the background so I could read a book on Kindle - I don’t need to stare at the workout graph the whole time. The TR timer continued to run, but the app disconnected from my trainer.

I have a camera tripod with a phone mount so I can position the phone within easy viewing and swiping distance. I don’t want to do this twice.

1 Like