During a 20 minute FTP test TR switches to resistance mode but my KICKR bike does not

Hi all,

I usally zwift but i was planning to do some real training and decided on TR. Adaptive training looks cool. So i tried a few workouts and now it was time to do a FTP test.

Everything started fine, the test tells that it will switch to resistance mode during the 5 and 20 minutes high power parts and i can see in the desktop that just before the 5 minutes of high power it actually swicthes to resistance mode. But it looks like it doesnt tell my kickr bike to do so and keeps me at the same wattage as the interval before :frowning: (

I switched from bluetooth to ANT+ (turned bluetooth off on my laptop), turned ERG smoothing off but nothing. I wonder if its me doing something wrong or the KICKR bike doesnt like TR ?

Any suggestions are appreciated as i do like the training TR offers but without the FTP test it misses essential functionality for me

cheers

rene

It’s probably a good idea to email support@trainerroad.com so they can review the logs and see stuff we can’t even access here on the forum.

1 Like

Ok i’ll do that

cheers

rene

Something similar happened to me before. I am not sure if was using a Kickr or Neo at the time but the solution was to go into the trainer settings on Trainerroad and turn up the resistance level. Mine was set to 0 by default and I could not generate enough resistance. Moving that up a little fixed the issue for me.

1 Like

According to Wahoo, Kickr Bike doesn’t support Resistance Mode. There is a way to change trainerroad app to support the Kickr Bike, see support link. I havent tried it yet. With the the 20 minute test I did yesterday, I used the Wahoo app in Level mode as I didn’t have the answer from TR support with enough time (thry replied yesterday morning) for a dry run before my test. I plan on trying thr support solution tomorrow.

1 Like

Great catch! I totally missed the the full “Kickr Bike” mention. That is very possibly the key detail here. Hopefully TR support can confirm that or point in a different direction as needed.

My Kickr bike never dropped to sim mode by itself. Ever. If I wanted it to trip off ERG, I had to force it. Just check your gearing. I did it once, and didn’t realize I was way up in the big ring. I felt like I had been thrown off a dragster into a brick wall.

This doesnt work. I let the trainerroad app running on Mac OSX, fight for a while… only choices i have are Resistance and Erg. Resistance changes for a moment, then goes back to the erg setting. To make it worse, it was ramping on all pedal strokes at low cadence work, like a belt was slipping (but it wasn’t). When I shut down the TR app, and lauched the Wahoo App from my Android device, everything worked correctly, but I have to chase the target power on my Garmin (not connected to bike), which hosted the workout, like outdoors. TR is not correctly integrated with the Kickr Bike, at least with my version of the app (most recent update), and the Kickr Bike (fully updated firmware). The Bike doesn’t support resistance mode, but it does support:erg (local), sim, levels, and pass-thru ( external app control). Kind of dissapointing, as the bike is super awesome. It works with Rouvy flawlessly, making me think it isn’t the Bike.

The best way to be sure is to contact support@trainerroad.com so they can check out your internal ride log and see whats causing issues. They’ll be happy to help! Sorry for the trouble.

There is an active support case, but it sounds more widespread than just me. Like all things at TR, improvements happen pretty quickly. Thanks,

1 Like

The thing i found on the Wahoo site is this (thx iceaxe)

So the KICKR bike doesnt support resistance mode Which would explain the strage behavior. And leaves me with me limited support for TR

Update from support this evening… Not encouraging, and no timeline to fix.

Since Wahoo says that the Kickr Bike doesn’t support resistance mode, and we’re offering it, I can’t say for sure what’s happening. =(

That being said, we’re going to test some things out on our end to see what could be happening and figure out if we have an issue that we need to address. In the meantime, if you want to train with a different platform, I understand and hope you’ll consider coming back eventually. =)

If you have any questions about this, feel free to give me a shout; otherwise, I’ll let you know what our team figures out after we test things out.

Best Regards,

Nate V.
Customer Support Expert