TrainerRoad workouts not syncing to Garmin Connect

Since 10th December 2021.

I tried disconnecting and connecting the “sync” on both sides, and Garmin is not “pulling” data from TR. I am filing the bug here first, and if this doesn’t work, I will file a bug on Garmin’s side.

5 Likes

I think it’s a Garmin issue as I’ve had Zwift rides also not pulling through to Connect over the last few days as well

Yea, definitely a Garmin issue. Pushing to Strava works, but yesterday only 1 out of 2 workouts got synced with Garmin and today none of 2

Currently got the opposite problem: Strava rides aren’t appearing in TR. They appear in intervals.icu, Veloviewer, etc. but not TR. All Strava rides are public. TR workouts appear in Strava so the link is there, one way at least.

Same issue: just completed a TR workout and it’s not syncing with Garmin Connect. Tried disconnecting and reconnecting GC from TR twice, to no avail.

I’m having the same problem.
My workout on the 10th synced normally, but not on the 11th or 12th. Tried relinking the accounts to no avail.
Had to resort to downloading the .fit file and manually uploading it, which garmin recognized as a TR workout.

Yep, seems to be a garmin issue, i had a ride where i did the Tr / Zwift double, both populated on strava, neither on garmin connect.

Disconnected/reconnected, and uploaded fit files manually as above.

Me 2. I changed my prescribed ride and opted for the outside option but it never got to garmin connect or my garmin head unit.

I’ve noticed the same thing - no 3rd party activities syncing to Garmin.

The timing seemed to relate to the big AWS outage but that should have been sorted ages ago?

The timing definitely adds up. Some cronjob stops running, and no one notices - cuz batch jobs have no alerts. Or some such. I will file a bug on Garmin forums as well.

It seems like Garmin Connect has the latest workouts from TR now. I guess the cronjob was started by someone after all.

Mine seems half fixed last night neither my ride on the 11th or earlier in the day on the 12th had loaded. When I just went into Garmin to manually enter my swim it was showing my ride from the 11th but still nothing from the 12th. Didn’t change any settings or attempt to reconnect. Guess I’ll check later to see if it grabbed the ride from the 12th before I manually add the file.

Through the chat desk here is reply to todays workout not syncing
(04:22:19 PM) Bryce L: The Garmin Servers went down this past weekend, and they just went back online this morning. We are reprocessing the backlog at the moment, so it may take an hour or two to sync over to Garmin Connect.

hmm, the weird thing is I step on a Fitbit scale every morning, and via MyFitnessPal (MFP) it pushes to Garmin almost instantly. That was working just fine since 10th December, as was syncing TrainingPeaks workouts to my Garmin 530. So if the Garmin “servers” (plural) went down, either some were still online (Fri/Sat/Sun/Mon mornings), or they went down and came back up. :man_shrugging:

1 Like

I’ve had no problem at all syncing TR/MFP/Strava/TP/Intervals.icu/Connect, so something weird is happening. It’s not impacting all users.

1 Like

I had this issue the other day. I had to manually upload .fit file from TR to Garmin Connect. Did the unlinking/re-linking thing with my third party apps to Garmin Connect. Apparently, only new workouts done after the re-linking will upload, and not past rides. The TR workout I did today uploaded to Garmin Connect and my other third party apps with no problems.

Support at Garmin Connect was less than helpful. They gave me a link to the FAQ page that I had found and had read on my own. No mention of any issues on their end. Just told me to contact my third party apps because it must be a problem on their end. :roll_eyes:

For me, the rides sync but it doesn’t give any credit for Intensity minutes. But the ride is right there in the Activities folder. Very weird. I tried Garmin support but they were unhelpful (told me to undo and redo the handshake between GC and TR, which wasn’t the issue and didn’t help. ). Clearly, there is something weird about how GC grabs intensity minutes because all the data about HR, power for the rides comes through, but it won’t “see” it in terms of calculating the minutes.

2 Likes

I spoke with Garmin and third party apps don’t contribute to Intensity Minutes or Training Status. The support person directed me to the suggestion area for the Garmin developers, which I followed up with. Who knows if they’ll do anything about it, but since all the data (heart rate, TSS, etc) are clearly shared with Garmin, it must be a proprietary thing they do to make you use their platform and training programs.

1 Like

Thank you for looking into this. When I contacted support at Garmin, they really didn’t have any interest in looking into it and just said it must be a glitch with TR. But this makes much more sense. I could see that all the data was shared. It’s a bit odd how it uses the data for some features and not others. Thank you again for looking into this.

You can close out this query, Happy New Year,
Karen

1 Like