PowerMatch Experiences

looks good to me!

When you turn powermatch off, the data looks very smooth. I only see it that smooth when using the kickr as the power source, the power reported by the kickr has a lot of smoothing applied, or it just displays what you want to see, one of the two!

I am aware that the graph is artificially smoothed after turning off Powermatch. However turning it off let me finish the workout while I was heading to VO2 max zone only 3 minutes into the first 12 minute interval with it on. I also realize that it was likely easier thereafter due to my Kickr typically reading lower than my P1’s, however my FTP was set using my P1’s and it felt like the magnitude of the variability was much lower once Powermatch was off.

Maybe the variability difference was all in my head and it was simply easier because the power requirements were lower - I can’t say and don’t know that I care to dig any further to find out. Over the past few months it has been clear to me that the P1/2017 Kickr/Powermatch combo is garbage - especially over Bluetooth connection where the P1’s become an expensive left only power meter. Doesn’t appear to be any better for me with the new update. Perhaps it’s limited to my specific set up, but life has been so much better since going back to my Kickr only. I will just track FTP tests separately with a head unit off my P1’s for outdoor reference.

A couple of things, I’ve got a 2017 Kickr and Stages L/R power meter and a lot of testing comparing Kickr optical power vs Wahoo “power match” vs TrainerRoad PowerMatch:

  • using Wahoo Fitness app turn off power smoothing so you can see what Kickr’s optical power is actually reporting (instead of Wahoo’s default “fake smooth power” shown in your screenshot above)
  • on my setup, TR PowerMatch has a little more variability than Kickr optical power meter, and not enough to impact workouts
  • variability increases when I’m tired and pedaling is sloppy
  • TR PowerMatch is better in latest update
  • Kickr optical power meter will drift up and down over the course of a workout, therefore if you want more reliable power readings from Kickr, do a spindown on every workout about 10 minutes into the workout
  • my Stages right meter sends power to left meter, and left meter provides full L+R power to TrainerRoad app over Bluetooth

I’m a fan of having indoor and outdoor power measurement being consistent. I can’t see going back to Kickr and will continue using TR’s PowerMatch for consistent power data on the trainer and outside.

Hope that helps, and sorry to hear your P1/Kickr/PowerMatch combo is giving you trouble.

1 Like

The only trouble was figuring out the issue, now that I have identified it everything is great. It’s actually easier just using the Kickr, absent the second spin down 15 minutes in. Fewer things to deal with/zero and it’s consistent across BT and ANT+.

I continue to be a happy TR customer and advocate.

1 Like

I’m not 100% sure this is the right topic for this post but I use a 2017 Wahoo Kickr and a set of Garmin Vector 2 pedals with power match enabled. Regularly perform spin downs of the trainer and run the zero of the pedals before each workout.
I use a MacBook (running version 2019.4.0.88905) and the Garmin ANT+ dongle to connect to all devices (Kickr, Tickr and Vectors).
Normally I always run in an easy gear keeping flywheel speed and noise down but I wanted to test how the new app with improved powermatch would work using a harder gear. Tonights workout of Bashful +2 seemed a good candidate as I usually struggle on these VO2 workouts and wanted to see if having higher inertia helped with the ability to complete.
I ran the first two blocks of 5 intervals in my normal gearing (39/25 I think) and for the last set switched to something like 52/14. As you can see from the image it took way longer for each interval to get up to target power than in the previous two sets but then seemed to continue to climb above target almost as if it was trying to average itself out. For the length of each 90 second interval the actual power did average itself out so from a summary table all looks normal.
I’m assuming this was all related to flywheel speed and the inability for the trainer to react to target power? I tried to keep cadence steady going into the intervals but I will admit that it drops during each interval as I just can’t keep pace. Really interested in thoughts as taking 20-30 seconds (over 40 in one case) to get hit target power seems a long time, even taking into account increased flywheel speeds.


2 Likes

I’m in something like 53x15 and typically see 3-4 seconds to hit target power:

You can see the cadence (white line) is fairly steady throughout (average of 101rpm), not quite flatline but close enough. You might see better results with a steadier cadence, or a more pronounced 1-2 second push on the pedals when jumping from 100 watts to 300+ watts.

Having given up for the last year or so I tried power match again last night for Mills + 3 for the vo2 max internals it seemed to act more a limit if my power ever got up to the desired level the resistance would reduce. I spent the whole internal having to add cadence and shift down until I was finishing in my smallest cog doing 100+rpm

I then switched to resistance mode for the remaining intervals which worked fine.

For the endurance section at the end of the ride I switched back to ERG mode and hit my power targets fine

Equipment was Android Phone (Pixel 3) connecting to 4iiii Left Side PM and Tacx Vortex Smart over Bluetooth, but I get the same issue using the PC app and ANT+

SAME PROBLEM HERE! It’s driving me crazy.

I’m starting to wonder why the hell i even use a smart trainer. We are all probably better off just using a standard trainer with dual leg PM.

I too have experienced delays getting to target power. Last night i did Bluebell and after i did a lot of things to my set up to clear up interference i felt like i didn’t have that delay or lag getting the resistance locked in. BUT…every time i would get up to a steady cadence and the resistance locked in my power would eventually drop and cadence increase …like the Kickr was letting go of the resistance. I posted about this this morning.

I’ve been working with TR support, Wahoo support, Pioneer…i’ve changed laptops, added USB ext, now dongle, disabled 2.4ghz WIFI, Wahoo replaced the Kickr SNAP, and Pioneer “fixed” my PM.

It seems like EVERYONE using a Kickr or SNAP has been having the same problems. I’m about to go to a standard trainer and use my Pioneer PM.

If you try to adjust your cadence or shift to hit your power targets while erg mode is on you will have a bad time.

3 Likes

image

5 Likes

My Powermatch was all jacked up the other day. KICKR was holding me ~20W over the target interval which was a problem obviously. I tried everything to fix (recalibrate, manual mode, reboot KICKR, recalibrate again) and the only thing that worked int he end was rebooting the iPad. 2 of 3 sets were not quality and filled with futzing around but I stuck out the last set and did the best I could.

I’m not sure what was wrong, I’m on latest update and it was fine 2 days earlier. KICKR seemed to have a mind of its own.

Could be worth contacting support@trainerroad.com so they can review the data and see what was happening.

I actually was, until I got it fixed. Now it’s more fun to lament about it on the internet. :stuck_out_tongue:

1 Like

Nate mentioned not shifting with erg - which normally I’d never do - yet I found today that was the only way to make the power match converge per below.

I was up for Taylor -2 (aka PowerMatch stress test? :smile:) in base plan and my setup was showing pretty bad lag and not converging to target on first couple of intervals.

I have Wahoo Kickr Snap, Stages L only power meter, erg mode with TR power match to let stages control, 50 big ring on front, ~19 on rear - usually works perfectly.

I expect a slight lag as it converges with each step. But I had not encountered this case of it never converging over a 30 second interval, leaving a 20W gap.

I noticed in this thread there was a new software release and confirmed that I’m on 2019.4.xxxxxxx

What I eventually found was that if I shifted one cog smaller on rear (~19->17) in sync with the jump in power, it would add enough resistance to help force the power to overshoot harder - and then it would settle back into the target power range, so this is what I did most of the time. (and shifted back at end of interval so I could kick it up again on next one) A couple times I tried to skip this and it converged OK, but not consistently. In particular, when last set came up, it was coming up short again, so I went back to shifting one click on the back by 3rd interval in final set, and with big spike to start, I generally hit or exceeded target for all the remaining ones. Consistently, the ones that were below target were the ones where I tried to let it just do the job on its own. No other bike computers/apps conflicting.

Reading this thread, best I can come up with is:

  1. If I go to small front ring, that could give trainer resistance more granularity to work with? Current setting was chosen largely b/c the speed/miles are well matched to reality for what I’d do on flat ride, just for sake of tracking my miles reasonably well.
  2. I had not calibrated trainer before this ride and rarely do - I didn’t think it mattered much using stages PM with power match unless I was so far off that it was beyond limit of compensation?
  3. Reducing smoothing time for display on short interval rides so I am not wondering 5-10 seconds in if it’s going to converge or not? It sounds like some of what we see as delay is not actually real - I’d never care in a 12 minute SS interval, but when you know it’s only 30 seconds and you’re 5-10 seconds in and still seeing it off, maybe it’s better to let it fluctuate more?
  4. Other ideas?

In general I’ve been finding PowerMatch a bit better since the update but if you didn’t tell me I might not have noticed. In saying that, I did Kaiser -1 this morning and at the start of one of the intervals it held me about 30-40 watts over target for 20 seconds or so. I felt that!

I probably should calibrate my Kickr more often. I get a bit lazy with it considering you need to warm it up first.

Well it seems as of lately that powermatch at the beginning of intervals is holding me way above the target power, seems that the only way to get my power to drop towards the target power is by reducing my cadence. This is frustrating as hell as for me at this time erg/powermatch is not usable, I end up in standard mode. Anyone have any ideas?

Hammer connected by BT and a rotor PM connected by ANT+.

What trainer are you using?

When using my kickr, if it is connected to the wahoo app, I have the same issue. If I disconnect my trainer from wahoo, connect it to TR, along with my power meter, power match works as it should.

My bad, Hammer connected by BT and a rotor PM connected by ANT+. I might just deleted everything from TR and then add them again.

Connect your Hammer via ANT+ as you have w/the Rotor PM.