Please help..🙏🏼 | Elite Direto XRT and Trainer Road continuously malfunctioning

Hi All,

Since last Spring ('22), every several weeks, my Elite Direto XRT and TrainerRoad arent properly working together.

The last time this was solved by a manual firmware update on my Elite Direto XRT.

Now again, it isnt working. But the latest firmware seems to be installed on my Elite Direto XRT.

After consulting the manufacturer, there also doenst appear to be a hardware malfunctioning in de actual direct drive trainer.

Could any body please provide advise or her/his own problem solving experience?

1 Like

Sounds like you have contacted Elite. What has TrainerRoad support had to say, assuming you have spoken with them already?

What exactly is malfunctioning?

1 Like

The generated watt-output doesnt meet the requested/demanded watts.

And also the cadans the heavily fluctuating, while (with almost 20 years cycling experience) i am convinced that is must be quite steady.

For large periods of time, my Elite used to function fine with TrainerRoad. But it appears that software changes/updates from TrainerRoad, and (delayed) firmware updates from Elite.

Hey @Vodegel , I am going to take a look into this for you just now to see if I can glean any info from our end. I’ll circle back around when I have more information and suggestions for ya!

Check out my thread here on a similar (maybe the same) issue: Direto XR ERG mode

In short, my Stages PM was interfering with the Direto XRT per TR.

1 Like

Hi Sarah, that would be much appreciated!

Please see a screen print from my recent training that clearly shows that the output that was mentioned during the training, was constantly much below the requested watts.

Also the cadans was heavily fluctuating.

I took a look at your latest ride, and I see what you mean. I have some questions and suggestions that should help us figure out what is going on here.

The log for this ride (the background recording of what is going on in the app when you are using it) has not synced over to us yet. Can you try logging in and out of the app to see if that prompts it to sync over to our servers? That will give me more information to work with.

In the meantime, I have some suggestions that should help:

  • Can you make sure to calibrate your trainer before every ride? Check out this article to learn how to do that: Performing a Calibration.

  • Let’s have you check to make sure you’re only paired to your external power meter and the trainer. We don’t want to pair to the trainer’s internal power meter, as this component is included when just connecting to the trainer. In the Devices tab within the TrainerRoad app, your trainer should only display once. See below.

  • Additionally, we’ll want to make sure we’re only pairing to the trainer with TrainerRoad, and not through any other app.

  • Can you make sure that your trainer is not paired to any other device or app? It may be helpful to close out of other apps and turn off other devices you are not using while training.

  • By the same token, check out this article to make sure your connection between your trainer and TrainerRoad is strong: Dropouts.

A couple of other questions I have for you:

  • Are you pairing the trainer via Bluetooth or ANT+? Have you tried pairing using the alternative connection method?
  • I see that you use the mobile app on your Android device. Have you tried using TrainerRoad on another device? For example, on your desktop? Is there any difference?

Thanks in advance if you can try these steps out! Let me know how you get on and if you have any questions for me!

Hi Sarah, thanks for your quick reply.

  • I have logged out and back in to the app. Hopefully you’ll be able to see the log files

  • Do calibrate before 100% of all my trainings. Otherwise the starting resistence of the training is on max, at the start of the actual training.

  • I connect my phone via bluetooth and my Garmin HRM is connected via Ant+. In de devices section, TR does show two options to connect to the Elite. But I only connect to the Elite via bluetooth. There is no second/dual connection to the machine/trainer.

  • The trainer is only connected to TR and there are no other connection between the trainer and other devices or apps.

  • Normally and since the start I connect TR to the trainer on my private mobile phone (Samsung Galaxy Flip 3). But the same problem also occurs of I open the TR app on my business phone (Iphone 12) and make a connection.

As said before, for a reasonably long period, TR worked perfectly fine on my Elite XRT, via Bluetooth on my Samsung Flip 3. I have the very strong impressions that software updates in the app, and delayed (or a hold of) of firmware uodates on the Elite (XRT) are causing the problem.

Hey Gijs! I’m going to shoot you a DM so that we can troubleshoot this further. I’ll circle back around on the forum when we have found a solution.

@SarahLaverty , I’m anxiously awaiting your reply. Reader’s Digest version: I have a Suito that, until recently, performed quite well. A couple months ago it began to experience everything posted above by the OP. Assuming it was the trainer, I attempted to run the problem to ground with Elite;s tech support, albeit with no success. Notably, during this process, I couldn’t connect via Bluetooth to Elite’s app. The trainer was visible, it just didn’t connect despite Elite’s troubleshooting. I ended up running the diagnostic via ANT+, and, unsurprisingly, the Suito passed, which reinforced my suspicion that this is a Bluetooth issue, but I can’t figure out with which party–TR or Elite–the problem originates, As an aside, this issue began right around the time I saw another post from another Direto user with the same issue.,…, which begs the question: TR or Elite?

Hey Kennedy!

I’m sorry that you are running into issues with your Elite trainer. I’m waiting on a response from Gijs but I will certainly circle back around when we have more information.

So that we are narrowing in on the issue you are experiencing and to avoid wasting your time, could you please send me a DM including the steps you have already tried with Elite’s support team? Could you also send me a link to some rides where you were experiencing this issue?

That will give me a sense of direction to move in. I look forward to hearing from you! And as always, we will post here once we have the solution.


@SarahLaverty , I’ll start with an apology. My last post was incomplete, and left the impression that my issue hasn’t been resolved. It has, but only by sheer luck.

Here’s the rest of the story. After contacting Elite tech support, I sent a DM to the other Direto owner, who informed me that he had paired his cadence sensor with his trainer setup. That simple act fixed his problem, but also reminded me that I had recently removed my cadence sensor from my setup. Why? Because I use Powermatch and assumed (I know, I know) that my Assioma powermeter provided all the data for the 3-way handshake between TR, Suito, and powermeter. However, after hearing of this simple fix, I reintroduced my Garmin cadence sensor in the mix (with a new battery) and…lo and behold, my Suito is good–nay, perfect–once again. Today, I went back to the other Direto owner’s post and noticed that I had overlooked something you posted during my runaround with Elite support: it was a link explaining how TR uses and prioritizes multiple cadence sensors. It was quite illuminating and completely cleared up my issue.

Bottom line: keep a healthy cadence sensor / connection in one’s trainer setup for a good experience. I hope this answers all your questions.


Aaaah gotcha! That’s great news! And thank you so much for relaying that info back to all of us!

Yes, it seems like too simple a solution sometimes; a strong connection to all of your devices is important for an optimal experience with TrainerRoad!

Glad you are all set! Happy training!

1 Like

For issues with Elite trainers, here is what we suggest. My DM’s are open if you have questions for me!

The fundamentals:

  • A good old-fashioned “hard restart” of the trainer could be handy to reset the unit. Unplugging for about 5 min (and leaving it unplugged in between use).
  • Ride in an easier gear. This will make it easier for Erg mode to work. The harder gear you’re in, the more resistance the trainer needs to put out to regulate your power level.
  • Do you have any other devices in the vicinity? For example, are there TV’s, laptops, wireless headphones or a wireless mouse near your training setup? If so, try limiting the number of wireless devices near your training environment to minimise interference from other devices.

If your Direto XR is overshooting/undershooting target power in ERG mode:

  • Some athletes facing this issue have been able to solve the issue with an EEPROM Update, which can be acquired by reaching out to Elite Support.

  • Finally, one of our athletes resolved their issues in Erg mode by trying the following:

  1. Cycle 10mins in Elite My E-training app to warm up the trainer

  2. Calibrate trainer in My E-training app and compare offset number from app with sticker below trainer base. Value should be within 5. I.e., 6568 on the sticker, 6566 in the app. This is the belt tension. If it is much less or greater, contact elite support to resolve the tension discrepancy. (Here is a video from Elite for tightening the belt:

  3. Here is a video from Elite for tightening the belt- Change belt and black Pulley

  4. Open TrainerRoad and forget the trainer from the Devices tab. Re-pair the device and calibrate in TrainerRoad.

  5. Do this every few weeks.

  6. Shift to 3rd cog from the top of rear gear and at smallest chainring. Erg mode works well if your wheel or cog is slow enough. It struggles more with big chainrings and the smallest cog since it takes time to ramp up and down resistance.

  7. Start your Workout in Erg mode.

  8. Pick a cadence and stick with that throughout. For sprints, it’ll take time for the trainer to catch-up.