Elite Direto Trainer Fritzing

Today when I finished my workout (which I bailed due to fatigue) my distance in Strava was only 0.5 miles. I’ve had elite direto for over a year. Initially had similar issue related to wheel circumference settings. However I have changed nothing recently. I tried to resent everything, recalibrate, redownload apps reset up trainer, nothing seems to work. I realize these are not real miles but they tend to match what I would do on road for similar efforts and I do look at it a little to monitor my workload. Anyone else having this problem all of the sudden?

Mine use to do this when I had it connected to my Mac via Bluetooth. It does not do this with Ant+

I’m using tr on my iPhone

So no ant+ available

Hey Nicshne!

That’s pretty strange that your trainer would start acting up all of a sudden. I would recommend reaching out to our Support Team at support@trainerroad.com so that they can look into your log files and see if they find anything out of the ordinary :slight_smile: . They’re experts on this type of thing, so othey should be able to get your issues sorted out :+1:


I did email support I have not heard back

Nick Schneider


I did hear back from support but they were unable to solve my issue. I was able to fix issues I was having both with trainerroad and Zwift. I connected to my direto with elemnt head unit over ant+ to control trainer. I then toggled through modes to passive mode which turns off trainer control. I then deleted direto from elemnt sensor list. Viola my direto then paired with my iPhone over Bluetooth and worked normally with trainerroad and with my Apple TV for Zwift normally. Weird but seems to have fixed issue

1 Like