Elite Direto XR - Erg Mode issues


I am having an issue with my Elite Direto XR in erg mode where the trainer is overshooting and then undershooting the power target. My old trainer (Elite Zumo) did not behave like this.

See attached screenshot of my latest workout. Connected via Ant+

It feels rather unnatural to ride as the power is fluctuating 20~30 watts over target then overcompensating to 20~30 watts below target continuously. I am concentrating on holding a constant cadence (rather than trying to power match), but this fluctuating resistance does affect my cadence slightly as the load comes on and off, likely adding to the feedback loop.

I also suspect it makes the intervals harder than necessary.

The trainer firmware is updated. I was wondering if there is a setting somewhere within trainer road or the trainer itself which maybe causing this? maybe power smoothing? I have had similar issues with Zwift using this trainer, so its possibly not on the trainerroad side.

I can see a few other threads on this issue but no recent ones or resolutions.

Anyone else experience this? any help would be appreciated

My first thought is to ask what gearing you’re using. If the gearing is having trouble holding the power target, it can be because the gearing is too high. It may help to solve this by moving to the small chain ring in front and pick somewhere in the middle of the rear chain ring. This makes it easier for the trainer to respond quickly to the fluctuations in power you are putting down.

That said, I also have an Elite Direto XR, and since the latest firmware update, my ERG mode, when I use it, has been much closer to target, even when I’ve been in the big ring in front. There are still spikes, but none so big (unless I’m seriously altering my cadence such as when going from seated to out of the saddle). So there may be something with your specific unit. If you haven’t already, you may want to contact Elite about this.

Finally, I’ll say that bigger spikes and valleys are my realistic to what is done outside, unless you are amazingly disciplined and careful. More often, I do my indoor intervals without ERG mode, and I regularly see those kinds of spikes. I’ve heard that the science is that, so long as the power averages out over about 25 seconds, those kind of power spikes shouldn’t matter. That said, I notice that your average wattage was a bit high. 6 watts isn’t huge most of the time, but for threshold intervals, for instance, that could be the difference between getting through an interval and failing.


Hey @Niv24, it looks like Support already reached out to you! Good call contacting them :slight_smile:

As per our Support email to you let’s try the following troubleshooting steps:

  1. Device Pairing: Ensure that you pair your trainer via Bluetooth only. Do not pair it both via ANT+ and Bluetooth, as this can cause interference. Unpair the ANT+ version of your trainer as well as if it appears as a power meter. By connecting to all of these, it can cause interference.

  2. Device Calibration: Perform a calibration on your trainer. You can do this in the TrainerRoad app. Regular calibration can help ensure accurate power readings.

  3. Trainer Reset: Unplug your trainer for 5-10 minutes before completing a workout in order to reset it. It is important to leave your trainer unplugged when not performing a workout.

  4. Interference: Ensure there’s no interference from other devices. Bluetooth works with a 1-1 pairing mechanism. This means that any other device may steal its connection. Close out any background apps, and turn off any other computers or head units that may steal the Bluetooth connection.

  5. Gearing and Cadence: Maintain a mid-ring gearing in the rear cassette and either a mid (if you have three) or inner (if you have two) front chainring. Your chain should follow a straight path from rear to front. Also, keeping your cadence as consistent as possible will help. Try your best not to adjust your resistance in anticipation of upcoming interval changes. Speeding up or slowing down your cadence before or after intervals can actually “confuse” your trainer in ERG mode.

1 Like

If you haven’t yet - check out my post from a while back regarding my Direto XR Erg issues. Specifically, the troubleshooting steps I used b/c of Bluetooth interference.

1 Like

I experienced something similar on my Elite Drivo recently and it was due to the trainer somehow getting stuck in Resistance mode rather than Erg mode like the TR app showed. I toggle back and forth a few times until it got into Erg mode and worked as expected. If this is the issue you’re having, it might also help to unpair the unit, re-pair it, and make sure the right mode is selected after pairing.

1 Like

Thanks for the responses.

I have a power meter on my mountain bike (12s mtb, trainer has 11s cassette so use my gravel bike on the trainer) so well aware of the natural variations in power as you cycle. Also used to do zwift races and riding zwift routes not in erg mode.

This issue feels like biking down a road while staying in the same gear ratio and cadence, but the gradient changes from +5% to 0% every 10 seconds as the resistance applied by the trainer comes on and off as it over and then undershoots the target power of the interval.

I had been using the big ring on my 2x, so will try the small front ring.

Also doing some digging into the problem came across an odd bug with the elite upgrade app for their trainers. It was saying I was upto date at firmware version 67. But, elite forums were talking about version 80!

Turns out you needed to log out and back into the app to make it realise there was newer firmware versions! Definite bug in their app so Hot tip for the elite trainer users.

Maybe worth letting users know about this bug if they are raising support tickets about elite trainers.

Will give it a go in a few days after the Easter break and report back.



OK so it was a firmware issue with the trainer. The elite update app was falsely reporting it was on the latest firmware when it wasn’t. Logging into and out of the app resolved this.

Now the power feels perfectly smooth on the legs as it should.

Before and after Screenshots attached for reference.