Elite Direto Control Issues

Just this morning, my Elite Direto connected with TR, but the resistance wouldn’t change in ERG mode. Any recent updates that could have caused this issue? I made no changes to my setup (windows PC, connecting via Bluetooth) and 2 days prior it worked no problem. Restarted computer, reset trainer, even tried connecting via Ant+, no dice. Anyone else have this issue? Thanks.

Had this a few times, but not recently. I think from memory switching the trainer to resistance mode and then back to erg solved it. Can u test it with mobile app ?

Recently had issues with mine connected via tablet. Support suggested using only Bluetooth or ant+ to control it and turning the other off. May be worth a try or drop support a message as they’re very helpful.

Thanks. Yup, I had an issue in the past where ant+ and BT were “competitng” its all BT now. Also tried on the mobile app, same issue. Next is to try a totally different platform. Frankly I’m getting sick of these issues. May go back to a dumb trainer and power meter.

Have you dropped support a note about it? I was ready to move on too as the drop outs were getting more regular. Managed to resolve it…

1 Like

Hi @mbrunskie, did u figured it out? I now have the same issue for the first time after owning the trainer for 2 years. Cannot seem to solve it.

Thank youy

1 Like

Drop support a note and see what they suggest - someone else’s problem may not be the same as yours…

Hey, yeah. I contacted Elite and they confirmed it was a hardware issue. They sent me a new electronic board to install, which was pretty easy. Fixed the issue. Regardless, I’m ebaying my Direto. Dealing with Elite customer service was less than ideal, but actually not too bad considering they’re in Italy.

The way to test if it’s a hardware issue is to use the Elite My-Training app on your smartphone to control the trainer. If the resistance doesn’t change, it’s probably a hardware issue. Elite made me take a video of the guts of the trainer while plugging it in. Upon plugging in, the motor should move back and forth a bit and make a high-pitched humming.

1 Like

Amazing, tks a lot for your super detailed reply!

I’ve had the same thing happen to me and I tvought costumer service was actually quite ok. Had to filmit to confirm it wasn’t moving, then they sent board and video instructions. Hardest part was to calibrate it afterwards.

Thanks @gandlf, just received my board, installed and got the thing calibrated, however trainer looks “confused”when adjusting for the resistance. Did you calibrate it more than once?

I did, the number I got was outside margin of errors, and I had to adjust it a few times to get it right. I must say that the worst thing with the direto is the calibration in the Elite app. It works maybe half the time for me.

I recently ramped up my TR training and realised that no matter what I did with the powermatch (Assioma DUO) the watts were always to low and impossible to get up. I tried and failed with the calibration of the trainer. Not enough speed. I. solved that by changing the wheels size in the Elite app. Once I did that it was no probs. Also the updated Elite app is much more user-friendly.

However that didn’t fix my issue. So I revisited the process I did after changing the circuit board last year. As part of that you’re supposed to tighten up the belt until you get within 5 of the number stated on the bottom of the unit. When I did that I reached a number 4 away from the goal, but now I continued to tighten it till I actually reached the number and that solved the issue with my drifting power while using powermatch.

I was looking for a thread to post this in and this one seemed like a good choice. Hopefully someone will find it if they need it. To summarise, I fixed my drifting power by ignoring Elite’s recommendation and tightening the belt to spec and not just within ±5.