Oustide workouts (garmin)

I am still unable to get my trainerroad workouts to push to my garmin to do them outside. does anyone else have this issue? What am I doing wrong, or is garmin still not working fully after the hack?

Working fine for me. Are you scheduling outdoor workouts on the TR calendar a little ahead of time? You have selected the outdoor variant of the workout in the calendar? Have you used outdoor workouts successfully before? And you do have TR <> Garmin ride sync set up?

I also have the issue. Workout is in Gamin Connect calendar but not syncing to device. Edge 530 v6.00 and latest iOS Garmin Connect 4.34. I’m also having other syncing issues (segments) so probably a Gamin issue…

Yesterday I turned on my 530, created a workout in Garmin Connect on my iPhone, scheduled it on Garmin calendar, and minutes later 530 prompted me to do workout.

Last night new workouts for today/tomorrow were loaded in TrainingPeaks. Just turned on my 530 and those synced immediately (about a minute after main screen appeared on 530).

I’m not seeing any Garmin sync issues with the 6.00 firmware on the 530. I upgraded before Thursday workout, so 3 days in a row the syncing has worked 100%.

May not be something to try. Is your software up to date? I noticed this the other day after being prompted to update manually via Garmin express rather than it normally just downloading and pushing to Bluetooth on the app. So I dug a little and found this on the website. For reference I have an old edge 520 that I’ve not yet updated but have synced and completed outdoor workouts on this week. Maybe try that.

Syncing over wi-fi seems to work. iOS app version 4.34.1 was just released. This might solve the issue…

There may be a Garmin (or TrainerRoad) update you’re missing, or you may need to re-authorize RideSync! You should check in with support to make sure you’re all up-to-date, either by submitting a request online or emailing support@trainerroad.com. Sorry for the trouble, they’ll get you sorted though!

Anyone lost the sound notifications after upgrading to 6.00 ?
Only radar sound notifications were working during my navigation ride last Saturday and workout ride this morning

The release notes say

  • Removed unnecessary beeps for notifications that don’t need them

@GPLama pointed this out in his video. Obviously Garmin don’t you need them :slight_smile: It doesn’t explained what unnecessary means

I did an inside workout with my 530 -and- TrainerRoad desktop app, and every interval started with dueling countdown timers :joy:

1 Like

haha so you can’t miss next interval !

Well problem solved after a manual restart, basic way to fix issues :sweat_smile:

1 Like

this worked. I needed to re-authorize.

Thanks