Outdoor workout stuck at "Sheduled for Garmin"

Hi,

is there any option to manually start the sync to garmin connect for a outdoor workout?

I’ve just switched my indoor workout to a outdoor one, as we have nice weather today and I have some extra time. But the sync kinda seems stuck. After it was synced it should switch to “pushed to garmin”, according to the FAQ, but it stays at “sheduled”. It’s the first time I’m trying to use TR outdoor workouts with my new Edge 530. I’ve connected TR and Garmin according to the FAQ with all options and reauthorized it to be sure.

Funny thing, for my workout scheduled today it tells me “This workout was scheduled for 12th Sep…” (it uses past tense even if I haven’t even done it yet).

mountfield

Looks like you discovered an interface typo too :wink:

I’ve had this happen too @Frell – might take another couple of hours. Most have appeared almost instantly, but I found myself in a similar situation to you and it was the one time it wasn’t…

What about queuing it up again (Set as inside, save, set as outside, save)?

Thanks, it don’t what solved the issue. But when I wanted to start with my ride the workout suddenly showed up on my garmin calender and Edge. The workout itself and the feature is actually pretty awesome. I had a really fun ride and a good workout!

Hey @Frell.

I’m so sorry that your first experience with outside workouts got off to a rocky start.

Typically, when the workout is taking a while to sync, I first try deleting the workout and re-adding it to the calendar. Be sure to toggle on the outside workout again as well. Typically, this sorts things out and helps the sync happen more rapidly.

If this fails, I would then try disconnecting my Ride Sync from Garmin Connect, and re-connecting it.

Then repeat the first step of deleting the ride and re-adding it to see if that resolves the issue.

Sorry again for the trouble. If you start experiencing this on a regular basis, please reach out to our Support Team so that they can do some digging :slight_smile:

1 Like

Having a similar situation right now (typical, I have only ever done one outdoor workout and when I decide to do another the server is down) , re scheduled from indoor to outdoor but stuck at scheduled. Deleted and reinstated as outdoor from the start still the same. My phone Garmin Comnect app is saying that their servers are down so I assume this is a block to the session being pushed to my Garmin?

@Bryce ?

Not waiting any longer, switched back to indoors, it’s my birthday and there’s drinking to be done, need to get the session done :grin::grin::grin:

Go ahead and shoot our Support Agents an email at support@trainerroad.com so that we can take a closer look for next time.

They’re the experts on this type of thing and should be able to get things sorted out for you :+1:

(Sorry for the delayed response, it was 2:00am here :wink: )

Garmin connect is down at the moment. From their tweet “We are currently experiencing an outage that affects Garmin Connect, and as a result, the Garmin Connect website and mobile app are down at this time.” I cannot sync anything either so I guess I need to wait.

2 Likes

Hey @Bryce no worries, knowing where you are I totally accept that there is going to be a delay to a post us Brits make early in our day.

Just bad luck for me that Garmin is down on the day i was going to head out with an outdoor version. Never mind, another day maybe.

1 Like