Trouble syncing with Garmin Connect

Since i turned on outside rides my TR workouts don’t show up in my GC.
I’ve turned it off and back on a few times and tried to re-sync the two rides with no luck.
Anyone else have this problem

Have you contacted support@trainerroad.com to review the issue?

1 Like

No.
I figured I’d see if anyone here had the same issue first.
Thanks Chad.

1 Like

What’s this panel doing for you? https://connect.garmin.com/modern/settings/accountInformation

2 Likes

Hey @CatfishRacing!

I am sorry to hear that your Garmin Connect sync has been giving you issues! We have actually been working with them on a current issue where our rides won’t upload to Garmin Connect. It may be that this issue is giving you these problems as well.

For now, I recommend that you disconnect your Garmin Connect RideSync. Then, you can re-enable the sync, and ensure that you have allowed the share of both your workouts and activities with Garmin.

If that does not help, just let me know and we can get a Support Ticket going to get this fixed for you. :smile:

1 Like

ive had the same problem today - previously theyve uploaded fine from the beta site, but neither of todays rides have synced

Ive just disconnected and reconnected, resynced the rides but not showing yet - Ill see if it works on tomorrow morning’s (indoor) ride

Hi all. I am having the same problem. I did a workout on Tuesday that synched immediately. My workout today didn’t get synched. Revued the Ride Synch page and Garmin section keeps indicating to ‘re-authorize Garmin’. I did re-authorize 5 five times, disconnecting and reconnecting. Flagged all items. Nothing.
Strava on the other hand synched immediately after workout.

Yepp idem problem as described above.

Hey Guys!

I just want to pop in here to add a quick note that I didn’t really make clear earlier:

We are aware that there is an issue going on where TR Workouts will not sync to Garmin Connect. We are currently working with Garmin to get this fixed as soon as we can. So, stick with us and we should be back up and running in no time. :slightly_smiling_face:

For the time being, your best bet will be to manually push your workouts to Garmin Connect. This is done by clicking the GC Icon at the bottom of the Ride Analysis Page.

If that does not work for you, then you will need to manually upload your TR Workouts to Garmin Connect. The articles below will show you how to do that.

Upload to GC: https://support.garmin.com/en-US/?faq=Ht3ZP52Kju075uKvqTqu99

I hope that helps! Thank you all for your patience as we get this fixed! :+1:

1 Like

I tried that 2 or 3 times with no change.

Same here on all counts.

I managed to chat with support and explained the problem. They were able to push my todays workout to synch with Garmin Connect, but did acknowledge through mysterious channels that Garmin has indeed a problem on their side. This to say that it is NOT a TrainerRoad issue. All of our workouts are trying to synch but are failing to do so on Garmin side.

1 Like

I am sorry to hear about that! I went ahead and started you a Support Request. So, you should have an email from me in your inbox!

If you don’t mind following up with me there, I would be happy to help get this figured out. :smile:

As always, if anyone else is experiencing an issue that they would like the TR Support Team to look into, please send us an email to support@trainerroad.com. Thanks guys!

Welcome to the world of Garmin connectivity

Not working for me either through sync, or manual pushing the button as above. Back to the old days via dropbox!

The Export-From-TrainerRoad and then Import-Into-Garmin worked for me.

This was an especially important workout to get imported because it was so hard, and yet I managed to complete it. It WAS going to get imported, one way or another. :slight_smile:

3 Likes

having the same issue I have disconnected all sync’s and reconnected with no change.

Same issue for me

Having the exact same problem. I don’t look at the Garmin data that closely, but it just stopped syncing with TR after August 3rd, so just noticed. Disconnected the apps and reconnected and no go - exact same issues as others have outlined.

Go ahead and report this to our Support Team at support@trainerroad.com and we will see if we can get this issue resolved :+1:.