No HR displayed with Garmin Dual HRM

Just switched from Zwift to Trainer Road because of previous connection issues (my cadence sensor/HR would randomly drop).

TR has been much better with connections but for some reason my Garmin DUAL-HRM will connect but the HR just shows up as “–”. It is connected by bluetooth
I have troubleshooted by making sure the sensors are wet, no other bluetooth connections, Redownloaded TR, restarted my phone, and made sure it connects to other apps.

Is there anything else I am missing? Anyone else have this issue?

I’ve been having the same issue this week (no issue in the weeks prior).

Garmin dual HRM shows as connected and shows actual HR when checking my devices in the TR app (windows laptop). However, when in a workout HR shows as —.

HRM connecting and shows data on garmin 530.

Just suggesting the obvious. I have found Garmin HRM go through batteries. Try changing the battery.

I have the same problem. Or to be more precise, I can’t get the HR data on my iphone even if the HRM is connected. This is on all apps, Zwift, Strava, Wahoo Fitness etc. Funny thing is it still works on my older iPad.

Unfortunately there isn’t much info on the google-net. For me the problem started pretty much at the same time when I updated my iphone to the most recent iOS. But I don’t know if that’s the reason. According to google it doesn’t seem so.

I called Garmin and they will send me a new HRM. Hopefully that will fix it.

EDIT/UPDATE: the HRM works fine on my Edge 530

1 Like

I have the same problem as well. Dual HRM pairs to my Garmin 530 and displays the the HR, but doesn’t for Trainerroad. Are you running the Beta version of the iphone app? That is when my HR monitor stopped displaying the heart rate FWIW.

I have the same problem. Interweb shows people having this issue throughout the year. I started having it a month ago, not sure what changed.

Works fine on my edge 530 but seems to have issue with my iPhone (either TR app or using it to connect sensor on zwift). It worked yesterday through Apple TV with zwift.

My best guess is an iPhone issue, but I haven’t found a solution. Have tried unpairing, making sure everything else is off, etc. I have a different BT HRM that works fine with the iPhone, so who knows…

Same issue here as well. Battery shows at 85% so that isn’t the issue. I have it paired with my Garmin 945 and off my wrist and it shows the HR fine.

Googling seems to indicate it might be some issues when its connecting across multiple devices but as far as I can tell there’s no way to check what devices the HRM dual is connected to

Had the same Win10 desktop.
Hit Forget Device and re-paired.
Works Ok now

2 Likes

That’s interesting.
My battery is also stuck at 85%.
I’m emailing with TR support services - I’ll let you know if something comes of it.

I’ve had an issue since I switched to the Garmin Dual about a month ago. I run the app on my iPhone (or MacBook) and simultaneously run my Garmin 1030. I have found that I can only be connected to 1 Bluetooth device at a time, and it seems to remember the device it was last connected to. Since the most important place for me to have the HR data is the Garmin, I turn off Bluetooth on both my laptop and phone, start the 1030, ensure it is connected to the Dual, and only then enable the phone/laptop. I will then get a steady connection to the 1030 for the duration of the workout.

1 Like

Maybe I’m missing something here, but why not connect the Garmin Dual to your iPhone/Mac via Bluetooth and to your Garmin 1030 via ANT+? I do that (tablet=Bluetooth, 1030+= ANT+) and it works great.

Nice catch. I stand corrected. I am connecting to the dual with ANT+. I am then attempting to connect to the phone with Bluetooth and while it shows as connected, it is not displaying the HR on the phone.

1 Like

Hey everyone,

Just to update everyone.
I went through Trainer Road’s support team who were very helpful.
They ran me through a bunch of troubleshooting which didn’t help.
They finally suggested that maybe the Garmin HRM was the problem so I ordered a new one - and it WORKS!

Looks like the issue was with the Garmin Bluetooth. So interesting.
Hope this helps someone in the future.

1 Like

I had the same issues as here described, HRM worked fine on all devices and all apps, except on the iPad. On the iPad it connected to the HRM, but got no HR data.

This happened after I had to change the batteries on the HRM as old ones were empty. After that, the TR app on the iPad just gave - - as heart rate, while e.g. the garmin computer was showing HR.

What solved it was to fully reset the iPad. Restoring from a back up would just bring the problem back.

Solved with complete phone reset.

I experienced the same issues with the Garmin HRM and cadence sensor both reading null (–) on my iphone XR but this only happened after updating to the new TrainerRoad IOS app, released in March. Prior to that they had been working fine since I began TR 9 months prior.

After trying many different things with the help of TR tech service, I tried resetting my phone and did a restore from a backup that I had created. That still do not solve the issue so I did a full reset and this time setup the phone as a new phone, meaning I had to manually install all my apps and set up email again. It was a bit of a pain but it solved the issue and I once again have heart rate and cadence data.

Similar issues for me. Worked fine on my iPhone. But I had the same problem as above on my iPad (showed connected in IOS BT settings, showed connected in TR app Devices but didn’t display my HR).

The Fix
I eventually fixed it by re-seating the battery in my HRM Dual and then going into General > Settings > Reset All Settings. When my ipad came back online, I had to re-pair the HRM (both in IOS Settings and in the TR app). And then the TR finally started reading and displaying my BPM in the workout screen.