Mac TR Application Bug?

I’m currently using OS X El Capitan (10.11.6) and TR Version 2018.39.0.84771 (2018.39.0.84771). I’m getting odd artifacts while using the app such as the one shown in the attached file. In addition, my “TrainerRoad” menu shows duplicate options for “Quick TrainerRoad” as well as an option for “Quit and Keep Windows”. I have completely deleted the app and reinstalled clean (after renaming the TR directory in my own home directory) and still see the issue. Any ideas? The program seems to work fine, but something is odd and it’s only with this latest update.


Correlation or causation?

Rendering I’d look at memory first. What else is open? How much is left to render the app?

My IT support days are long gone and only my grandparents appreciate my opinion.

I’d opine this kind of looks like memory.

Good luck m8.

1 Like

I’ve observed this too. I took a pic of it on October 25, I hadn’t noticed it before then.

I’m also on 10.11.6. Seems to be purely cosmetic so it hasn’t impacted my workflow.

1 Like

I reported the same two issues last week. I, too, am on a MacBook running El Capitan. First, when the Power, Target power, Cadence, and (presumably) Heart Rate numbers go into 3 digits, then back to 2 digits (i.e., go above 100, then below 100), artifacts of the 3-digit number remain on the screen. Second, I’m having to Force Quit the app. Neither TrainerRoad->Quit TrainerRoad nor TrainerRoad->Quit and Keep Windows actually quits the app.

I’m guessing they used to clear out the memory occupied by the 3-digit number before rendering the new 2-digit number, and now they’re not. The left-most part of the 1st digit in the 3-digit number remains, as does the right-most part of the 3rd digit.

1 Like

Would you mind reporting this to our Support Team at They have a procedure for documenting all instances of a bug so that we can track and replicate the issue in order to resolve the issue as quickly as possible.

Thanks so much!

I also get the heart rate, cadence and power values climbing into the high hundreds, i fixed it by pausing workout and removing and plugging back in the Ant dongle, although this may not have been it.

It was ok today for me doing Petit but i hope fixed soon cos annoying if it happens in an interval.


Command-Q will quit the app gracefully on mac.

1 Like

I did report it to on Nov. 1, and received an automated response, but no follow-up. Should I report it again?

1 Like

Thanks re: using the Command-Q keyboard shortcut. It’s puzzling that quitting via the menu doesn’t work, though.

1 Like

Hey Lee,

I just checked and your message is still in the queue. It should have a response by tomorrow or so. Sorry for the long delay, our Support has been absolutely swamped with tickets recently.


1 Like

I just received an email from a support person who was able to replicate the problem. He thinks it is now fixed in the beta here:



Cool! I submitted a support request with exactly this issue a couple of hours ago. Will try the beta, see if it works.

I tried the beta (briefly), and it seemed to work. Also, IIRC, I was able to quit the beta via the menu.

I saw this once myself but it went away. I can’t remember if I was using ANT+ then or not though, if that’s part of the cause

Just tried the beta and while I can get it to load, I can’t scroll anywhere within the calendar and clicking on Workouts or Training Plans (or Devices for that matter) results in no change. i.e., The beta doesn’t work for me much at all. But it /is/ a beta.

I got the same last week and took a picture of my imac. Not sure if it is in the file though.

And… (thread starter here)… I’ve updated my Macbook to Mojave and the problem went away entirely. And Mojave doesn’t seem to affect performance on the laptop so I’m sticking with it (it’s a 2014 Air, 13" 1.4 GHz if that’s useful to anybody).

1 Like

what a joke! when i upgraded to Mojave, the CPU usage went to 48% rather than 120% as it was before when I was running El Capitain. That is a major bug, and they should be ashamed to release such a horrid version of software.