Is anyone using the TR OSX app with Mojave?

just wondering if it all works ok as was going to upgrade today?

thanks in advance!


I’ve found it’s been crashing as I start pedalling when the workout is loaded so I’ve been using my phone for the week. Not 100% certain if the Mojave update is the cause, but seems to have coincided with the update.

I have been using Mojave on my MacBook without any issues. I upgraded to Mojave in the first week it was released and have been doing 4 workouts per week. My setup includes a Kicker18 and Garmin speed and HR sensors connected with the Garmin Ant+ adapter.

1 Like

All good for me :metal:t2:

I haven’t had any problems either.

Are you still in the Beta program? I found the same on the 10.14.2 beta update and reverted back to the public 10.14.1 and everything was ok.

I don’t think I’m in the beta, but will double check when I’m home what version I’m running

TR won’t work with my latest version of Mojave 10.14.3. Won’t open.

@bak5557 After you upgrade TR on OSX, go to the Applications folder and launch TR. I forget if it will launch w/out a dialog box or not. But if a dialog box pops up, say yes/ok. And if there was a dialog box, it only appears the first time you launch TR. The next time you launch TR it will not appear.

Thanks, but the dialog box doesn’t open long enough to say yes/ok. The beach ball spins, the there is a blip that is probably a dialog box, which closes immediately. I’ve completely deleted everything related to trainer road, emptied the trash, and reloaded trainer road, but still not working. BTW, the version I have is 10.14.3

All good for me…haven’t had an issue.

Only problem I have has nothing to do with TR…bluetooth on mac stops working when it feels like it and I have to restart to pair PM via bluetooth. Not a Mojave thing…just started happening last month.

1 Like

SNAP - happened to me yday - on High Sierra - had worked all week then BOOM all devices disappeared! - 2 restarts later still no bluetooth connection, luckily had phone as back up but not the ideal way to start a 2 hr Sweetspot session! haha

Tried a clean reinstall today so will update on whether it works later

Its hellava annoying. Luckily mine always works on restart (touch wood!!!)

i always run my garmin 820 through every workout so if there’s a drop i still collect all the data as TR on OSX drops power at least once every 2-3 weeks …

I too am running 10.14.3. I have had zero issues with TR starting up, running, etc… Are you launching from the Dock or from the Applications folder? Make sure you launch directly from the Applications folder.

You can also try looking in /Users/**YourUserName**/Library/Preferences for a TrainerRoad .plist file. If you find one, delete it. Then try restarting TrainerRoad. .plist file is a preferences file. Sometimes they get corrupt and cause issues. I say, “If you find one” because I have not personally checked to see if TR has one. I am on a different computer at the moment. I am guessing it will be named something like com.trainerroad.plist

@Travisza @sandilandscycles You might try deleting the Bluetooth plist for your Mac. It is located in /Library/Preferences

and named After deleting this file. you will need to restart your Mac.

When I get home, I will double check my Macbook for these files, their locations, and contents. Then, I will update this thread again.

Thanks. I have read about deleting the plist file for bluetooth…just haven’t gotten around to it yet. Will try tonight

A bit useless of me considering how its annoying its been.

I did a clean reinstall last night - with an uninstaller app - so deleted plist / caches etc

Re-dowloaded and launched from applications folder not dock and all worked fine … hopefully that has sorted things.

1 Like

@bak5557 Here you go for the TR plist (prefs file)

  1. Open Finder
  2. Command-Shift-G: type ~/Library/Preferences
  3. Find com.TrainerRoad.Mac.plist
  4. Delete
  5. Restart TrainerRoad

thanks for your help. I’ve tried all of the above, and still can’t get TrainerRoad to work on my macbook. It just won’t open. It’s the only program I’m having a problem with. There must be something with the latest version of Mojave and TrainerRoad.

The real frustration is that I’ve encouraged all my athletes to use trainer road and now I can’t even use it myself. I’m not completely computer illiterate, but I don’t want to spend my whole day playing with this. :-/

Beth A. Lamie

Pegasus Elite Athlete Management
The Wheelhouse Cycling Studio

Follow us on Twitter @team_pegasus

I have TR installed on multiple MacBook Pros running Mojave. No issues. While I seriously doubt it is a TR issue, I would open a support ticket with TR via email or live chat.