Issues After Windows 10 Upgrade

I recently had an automatic update/upgrade to Windows 10 a week ago and since then I’ve been having issues with a) TR “dropping” the ANT+ signal from my Garmin speed sensor (changed batteries 2x) and b) Netflix playback hangs up when TR is running.

Very frustrating as I’ve had this setup for 2-3 years with zero issues and I use TR 4 to 6 times a week. Has anyone else had any issues since the Windows 10 update? My laptop is an HP if that helps.

Thanks!

I need to find where I saw it, but apparently Windows latest update broke something…
I can’t remember the specifics, but I am guessing it is related to your issue. I will see if I can find it.

I also recommend sending an email to support@trainerroad.com to get the best answer directly.

Awesome!

Thanks!

1 Like

I put that update off until earlier this week. Oddly when it rebooted, TR was gone all together. Upon re-installing it worked just fine, though. It wasn’t just a missing shortcut either. The whole folder was missing and a search came up empty.

Weird. I emailed TR support but no reply yet about this issue.

I had the same issue last week as well.
Running an old laptop and after that windows update it became impossible to do workouts.(20+ dropouts during Taku, some lasting almost a minute)

Decided to do a 100% fresh windows install from an usb-stick and haven’t had a single dropout since.
I know it’s not an option for everyone ,but it’s pretty painless to reinstall and seems to have fixed the issue for me.

1 Like

Awesome! I don’t have Win on USB but I’ll start looking around. Thanks for the info!

1 Like

Straight from the source: https://www.microsoft.com/en-gb/software-download/windows10

Nice. Thanks for saving me a ton of digging around the internet!

1 Like

Unfortunately, problem still persists. Thanks to all the forum folks for the tips/advice btw.

Here’s my email to TR this am:

I have not received any reply from TR other than a generic “having trouble logging in?” auto-email. Please help.

My device (ANT+ Garmin speed sensor) pairs and stays paired for 20-30 seconds, then drops out for about the same time. This pattern repeats. TR is now unusable.

I have: reinstalled USB drivers, reinstalled TR, went to a previous version of Windows, reinstalled Windows 10, put fresh batteries in my speed sensor, moved my ANT+ stick to all 3 different USB ports, restarted my laptop, removed the battery and then reinstalled it and then restarted. No matter what, the problem persists, even if TR is the only app running at the time.

Please help. I have been a heavy TR user for YEARS with zero issues and now it’s been useless for about a week. I am disappointed nobody has emailed me back beyond a generic login email. I am beginning to explore other indoor training options as this is unacceptable.

… very frustrated right now.

This could be an issue with USB selectively suspending. Microsoft has hidden the “USB Selective Suspend” menu
You will need to edit the Registry for the USB Selective Suspend menu to show
have a look at this

If you google you will find out how to add the selective suspend option back into your power options

Awesome. I’ll give this a shot after work today.

Thanks!

Hey there,

I just wanted to let you know that I responded to the email you sent to Support. :slight_smile:

Thanks,

1 Like

I am having the same issue. Windows 10 updates on 2 computers, both worked before now neither do. Ant+ On is showing inside the app, but it is no longer finding my smart trainer.

I am having a different kind of issue after an Windows update this week, TR doesn’t login.
Windows 7 laptop works just fine, iOS iPhone/iPad also works, Mac OS no problem, Win10 trainer setup does not want to login, ‘generic something went wrong’ error message.

Would you two mind sending an email to our Support Team at support@trainerroad.com? (@tnash1991 and @DBR22)

These issues are best dealt with on an individual basis through Support so that we can properly track down the issues you each are experiencing. Troubleshooting through Support also allows us to track bugs more effectively and solve them more quickly.

We look forward to hearing from you!