TR not loading after yesterday´s MAc OS update

Hello everyone,

Did you also happen to have issues loading TR on MAC OS after updating the OS?

My last workout from the SuPB vol 1 was done yesterday evening. During the night my MAC updated and today I can´t load TR: I tried also via the terminal and no chance, for a fraction of a second a TR window pops up but can´t tell what it says, it´s too fast. Currently I am running Mojave 10.14.4. Attached please see a screenshot. Moreover TR is not figuring in the process list. Any help is greatly appreciated. Meanwhile I will try to do my workouts via my android phone and app.



Best to contact if you haven’t already done so.

Hi Chad,

Already did. I also reinstalled TR downloading the latest version from the website. No success…

I wait for a feedback from TR support ( I contacted.



1 Like

I managed to get a printscreen by making a burst of screenshots. Here it is:

Have you ever encountered this message? Is this somehow related with the fact I can´t open the app?



I don’t use Mac, so I have not seen that message before.

I use Mac and also have 10.14.4 OS, and I just tried and can open both the stable app and the beta app without problems, so I can’t help you with that.

1 Like

Hi again,

I used the android app (on my galaxy s8) for my workout today, however this revealed another issue: the Neo did not want to go to active recovery intervals, so I have been forced to do 70 minutes at sweetspot (I back pedalled closed the ant+ connection to ther NEO smart trainer and power meter, no success). Attached image (the spikes in power are because I stopped to backpedal and then have been forced to start from a full stop). Any help would be greatly appreciated.



Weird…Since today, it looks I can’t. I have had no issues since I am using TR for nearly half a year now, but somehow today it started giving me issues.

I hope TR support can help!

I also have no problems using 10.14.4, have you tried moving /Users/xxxx/Library/Preferences/com.TrainerRoad.Mac.plist out of its folder (maybe to the desktop) then starting TR? If it does not help then put it back.

No problems here…

Are you handy around the terminal? I would do a complete uninstall and get rid of all the TR stuff under ~/Library/ one of which is listed directly above.

Complete uninstall - only do this if you are comfortable using command-line
  1. Drag & drop from Applications folder to trash
  2. Open terminal and delete the rest of the TR files:
    cd ~
    rm -r ~/Library/Application Support/TrainerRoad/
    rm -r ~/Library/WebKit/com.TrainerRoad.Mac/
    rm -r ~/Library/Preferences/com.TrainerRoad.Mac.plist
    rm -r ~/Library/Caches/com.TrainerRoad.Mac/


Thanks for the hint. I tried it, first I had to activate “show hidden files and folders” as preferences folder under user was hidden. Moved the file to desktop, tried relaunching TR, no effect, still would not open. I will try and do an uninstall from the terminal.

Will keep you posted!

pfff…did all the above, reinstalled TR and still nothing: the TR icon after clicking on it does the typical popping move as it would open but then it stops and nothing happens… I am lost…

create a new user on your Mac, then logout, login as the new user, and try running TR.

Looks like there are other users with this issues: one of the posts (Is anyone using the TR OSX app with Mojave?).mSame behaviour with TR not opening a a window popping out for a fraction of a second.

I am however gonna give a try to create a new user and see if that helps.

Dear bbarrera,

Creating a new user and launching TR it works. Thanks! However I would like to make it work on my primary admin user. Do you know what could be the issue there? I did remove all the indicated folders related to TR. I guess there is still something related to it. I read on the other thread that it could be also Bluetooth related…should I also remove the Bluetooth plist?



Hi George,

Do this at the terminal:

sky:~ brian$ cd ~
sky:~ brian$ find . -iname *trainerroad* > TR-files.txt

and then post the results of the TR-files.txt file.

Mine look like this:

sky:~ brian$ cat TR-files.txt
Library/Application Support/
Library/Application Support/ Store/TrainerRoadTools.db
Library/Application Support/TrainerRoad

And thats why I told you to “rm -r” certain files/directories in my previous instructions.


1 Like

Hi all,

Thanks to @bbarrera I have now been able to solve the problem. Here are the steps I did:

  1. Remove previously mentioned files/folders and then
  2. Search for other places where TR information might be stored using " find . -iname trainerroad > TR-files.txt". This command will save the locations of TR relevant data on the “TR-files.txt”. In my case, the following extra 3 locations showed up:

“./Library/Application Support/CrashReporter/TrainerRoad_39371A41-F777-5B4A-9BC4-D7B2683DC23C.plist
./Library/Application Support/TrainerRoad
./Library/Saved Application State/com.TrainerRoad.Mac.savedState”

After removing these, and relaunching TR everything is back to normal. Thanks again @bbarrera!!!




the trick is searching for all files/folders under Library, and deleting those. The easiest way I know to do that is by using the terminal (because I’m 30+ year Unix/Linux/OSX geek) and running these 3 commands:

cd ~
find Library -iname *trainerroad* > TR-files.txt
cat TR-files.txt

And then deleting all TR related files/folders from that list.

Easy for me to say, a bit tricky for the average computer user.