How to Disable Virtual Cadence with Kickr 2021 and use a Wahoo RPM for Cadence?

I’ve been using TrainerRoad for the past three years, great stuff! I had a Kickr Core with a Wahoo RPM Cadence Sensor.

I recently upgraded to a Kickr 2021, which has virtual cadence. However, I still have my Wahoo RPM attached to my bike and the Sensor Profile is still an active device in my TrainerRoad settings.

Here is the kicker (see what I did there), TrainerRoad is only using the “Virtual Cadence” to measure cadence vs. the Wahoo RPM. Unfortunately, the Virtual Cadence is much less accurate, I have cadence spikes and find that it is very inconsistent when compared to the performance of the manual RPM Sensor.

Is there a way to force TrainerRoad to only use the Wahoo RPM Cadence Sensor vs. the Virtual Cadence in the Kickr?


I’ve been told that there is no current way to force a device in cases where there are two devices reporting. In your case, with a trainer and dedicated cadence sensor, TR is supposed to use the “most accurate device” for that data. We assume this means it will see the dedicated cadence sensor as “best” and use it.

How are you determining what device is giving you cadence, presuming you have them both paired in the Devices section?

If you suspect a real problem, you may want to email so they can review your logs and look at stuff we can’t here.

That’s true - the device connection interface, unlike that of Zwift, is limited to showing which devices are connected, not which device is used for what data. This is a rare case of Zwift’s UI being better at anything than any other app.

This said, I went through an issue similar to the OP’s situation (Tacx Flux S, flaky cadence reporting using a proximity sensor somewhere in the trainer), added a Wahoo Cadence, and I’m 100% certain TR has used that sensor’s data instead of the Flux - it’s pretty obvious when you look at workout results, that’s how bad the Tacx built-in sensor was.

I’ve recently ditched the Wahoo Cadence when I installed Assiomas, and again there’s no confirmation from the app that it uses cadence from the Assiomas over the Tacx, but I’m certain it does based on the data.

1 Like

Thanks all for taking the time to get back to me. Appreciate the community.

I don’t have an official way of knowing which cadence sensor is being used. I am assuming that TR is using the Virtual Cadence based on historical and empirical Cadence activity, I.e., my cadence is very spikey vs. being smooth like it was before when I had the Kickr Core or when I am riding in the real-world.

Is there an advanced setting to force or disable the virtual cadence?

Thanks in advance,

No, there is no TR option to directly control which device is used for any specific data.

I am also not aware of a way to disable cadence data from the Wahoo side either.

As mentioned, I suggest contacting TR directly to have a look at your files.

I have a 2018 Kickr with the updated firmware to broadcast cadence and a separate Wahoo cadence sensor on a crank arm. Once I paired the Wahoo sensor, TR always uses that for cadence - just spin the cranks before loading TR. You can click on the sensor block to see which sensors are paired and ensure the cadence sensor is there.

Why not just count your pedal strokes for 10 seconds, multiply by 6 and compare that to what you see on-screen? That should tell you if the sensor is the one being used…I think. As for the spikes, I get those often but I attribute that to a less than ideal pedal stroke.

Edit - I have a Stages LH power meter and calibrate every ride.

Thanks @pwandoff I like the old school strategy :wink: Alternatively, I could just break out my Garmin and sync the RPM.

The reason I think the virtual is being used vs the Wahoo RPM, I have a pretty consistent RPM at 95 @ Z2. I see fluctuations down to 60-70 RPMs, when I am not on a sprint or power output change.