Garmin 820 Fail / FW ugprade / TR component

I finally upgraded my Garmin 820 to the new FW which I believe is v10.0. During the last two rides, while moving, the speed dropped to ZERO and it stopped recording distance. However, the GPS was still working as it was recording my movement on the map page. After the ride Strava only captured up to the point where the speed/distance stopped, but the map in Strava showed the correct start / finish point. This is an odd one, it stopped showing and recording the data, but it did have the correct map and location data.

I had to do a “correct elevation / distance” in Strava to get the correct distance.

TrainerRoad naturally received the erroneous data, not the corrected data. I tried deleting and using GPX file but that still was incorrect.

Any one have any ideas what to do with the Garmin other than throw it in the bin where it belongs?


If you have a look on the Garmin forum there might be a procedure to downgrade to your last good working firmware.

Another option might be to do a factory reset with the new firmware installed and see if that sorts your issues.


I think I solved the issue by doing some research. It seems w/ the GSC-10 (speed/cadence) sensor paired means the Garmin prefers that over GPS. If the battery in the GSC dies (or is dying) speed will drop to zero but the GPS data on the map will remain active. So lesson learned, change the GSC battery.

I think I’m more amazed you still have a working gsc-10!!!