TSS/NP/IF Odd Sync

I should start off saying that this isn’t a big deal, but it’s the first time it’s happened, and I’m more curious than anything as to they why. :slight_smile:

Today I took a nice endurance ride while the weather was decent and did Pioneer -3 outside using my Garmin 510. Nothing I haven’t done a bunch of times before, only this time when the data synced to TR, the NP/IF/TSS were way off.

I calibrated my power meter before the ride, and my FTP is set the same in TrainingPeaks/Garmin/Strava, and the ride from my Garmin pushed to Strava and TrainingPeaks properly. All three of those essentially jive, with each doing it’s own minor adjustments to the data based on how they calculate things. And a lot of the numbers in TR match as well. For example:

  • Garmin: 664
  • TrainingPeaks: 659
  • Strava: 661
  • TrainerRoad: 659
    All fairly close. Same for my cadence avg/max, HR avg/max, speed avg/max, even power avg/max. However, whereas the NP/IF/TSS are fairly close for TP/Garmin/Strava, it’s WAY off in TrainerRoad. I tried using the resync button, but the numbers don’t change. For reference, I’ve included screenshots of the numbers from each.

Has this happened to anyone else? If not, again, not a big deal. But worth noting for the TR devs, in case there’s something else here. :slight_smile:





1 Like

Does your FTP in TR match TP/Strava/GC?


Ive been guilty of not updating them all after an AI FTP update in TR but if youve checked that I am stumped. Perhaps it’s a question for support.

Yeah, was the first thing I checked, thinking that it was off. But it’s always the first to update after my tests, then I have to go update the others. I’ll send it to support to see what they see. As a dev myself, I know sometimes these things are unexplainable. :grin:

What about deleting the uploaded workout, then uploading the workout again. Does it yield the same results?

That I haven’t tried because a) I didn’t want to mess with the workout/progression data, and b) when debugging, you can’t debug something that’s been deleted. :relaxed: So left it in place for now.