Calibration Failure

New to TR and having issues with pre-ride calibrations. Upon pressing calibrate TR immediately has a pop up with “calibration failure”, can “try again” until my heart is content or until I remember Einstein’s quote about doing the same thing over and over again. Factory spin downs (wahoo kickr), forgetting and reconnecting my PC, turning off and on all don’t reliably work. It eventually (10mins) decides to work. Very frustrating. We’re expecting our first child soon, unlikely my patience will be as long after sleepless nights.

Any help much appreciated.

There are implications above (Kickr?, PC?), but can you clarify exactly what device you are attempting to calibrate and with which app & device?

Cheers for the quick reply: Wahoo kickr to PC TR app (running Windows 8 v6.3)

Here is the Calibration procedure for a trainer (at the top).

  • Are you following this?

Sorry to hear about the issues you’ve experienced calibrating your KICKR!

We’ve had a few reports of calibration issues over ANT+ on desktop with the KICKR. Good news though — our latest beta release has reportedly solved it for these athletes! :grinning:

Could you give the beta a try for us? You can download it from the following link: TrainerRoad Beta

Let us know how it goes. You can also follow up with the Support Team at so we can take a deeper look.



Indeed. I rarely get given the chance to spin up, failure pop up comes almost immediately. When I get the chance I’ll start from scratch (again) through the wahoo app etc. absent anyone here having experienced, and fixed, a similar issue.

Just saw Nick’s reply, will try the beta, thanks!

1 Like

Sorry for the delay, new beta works perfectly. Thank you

I have just tried to calibrate my new Saris H3, using the TR desktop App running on a Macbook Pro and I’m getting exactly the same problem, i.e. the calibration failure pop up is displayed as soon as I click ‘Calibrate’, so I don’t get a chance to spin up to the target speed. Is this a TR bug?

It seems best to use Rouvy to calibrate the Hammer series trainers. For some reason, the TR access does not work.

Thanks very much Chad. I got a 30 day free trial of Rouvy with the H3, so I’ll try a ride and the calibration tomorrow.

You don’t need the paid or trial access to use Rouvy for calibration.

Here are the notes I have for running the calibration.

  1. Open Rouvy App

  2. Go to FREE RIDE

  3. If you have connected to Rouvy in the past, your trainer should be recognized and CONNECTED.

  • If you this is your first time you have to go through SELECT TRAINER process.
  1. CALIBRATE button is located under trainer name.

  2. Follow instructions to calibrate. Pedal to 19-23mph for duration of time requested by app. 20 seconds. But it generally takes roughly 25 or so.

  3. Stop pedaling when it tells you to stop pedaling.

Here is the connection info.

And the original calibration info.

I bought an H3 this week and my son was the first to try using it. Same set up with a MacBook Pro and failed calibration which caused a lot of frustration. He tried with his PC and it worked. However, he wasn’t not convinced that ERG mode was working. I was away due to work so will check this evening when I get back. @mcneese.chad have you experienced any ERG issues ?

1 Like

Brilliant! Thanks!

1 Like

I have not use an H3 specifically, but I never had ERG issues with my H1 and H2.

One possible thing to check, make absolutely certain that there is only one app the trainer with control capabilities.

I’ve made the mistake of having two TR apps running, or TR and Zwift running with control on, and you get very odd performance in ERG.

Essentially the two apps are fighting. One controls for a fee seconds at a power, and then the other. This creates a seesaw effect where ERG is changing frequently.

So, sometimes it’s best to close all apps and just have one open. In a pinch, I also reboot the trainer for troubleshooting.

Thank you @mcneese.chad; I found another solution, my son is 18 and he fixed it :grinning: will find out how when I get home !

1 Like

I’ve been meaning to start a thread about this very same issue, except I’m using a cheap Kinetic smart control. When I go to calibrate, I usually have to try 3-4 times to get it to work. Sometimes I can’t get it to work at all. It used to be that telling it to forget the device, and re synching it would make it work, but often now even that doesn’t make it happen. Anyone else have trouble with this?

I had this same problem from the first day but have gotten around it by powering down other Bluetooth connections. I’ve found that the Bluetooth connection between my Kinetic Road Machine Smart 2 and TR is very easily disrupted by any other Bluetooth connection (speakers, garmin watch, garmin HR strap, Apple TV). I pretty much can’t have any other Bluetooth connection going or the calibration won’t work which is quite a pain when you’re trying to listen to music on a Bluetooth speaker or screencast something to an apple TV etc…

Hmmm, might be something to that. I’ll have to look into it. Typically, I’m using an iPad paired with the trainer, and my phone paired with a bluetooth speaker. Last week I tried to do everything with my phone, as the iPad’s battery was low, and had all sorts of trouble.

I rode the trainer tonight, and didn’t start playing music with my phone/bluetooth speaker until after I warmed up and calibrated. It worked the first time, which it has rarely done before. Thanks for the suggestion, seems like I might have thought to try that before, oh well!

1 Like


I have just bought a bran new wahoo kickr bike and the calibration keeps failing.

Initially it failed on the “coast” i stop pedalling wait for the thing to stop spinning and it says calibration failed.

Now something has changed in the power and no matter how hard i pedal in the hardest gear it wont go fast enough to hit the 38km per hour?