Trainer calibration not working

recently I haven’t been able to get my Kicker Core to calibrate. I’ve tried several times, restarting software, resetting trainer (power down), checking for trainer firmware updates, to no avail.
The calibration screen sees me spin up to requested mph (14.9) and I see it coast back to zero and then nothing happens. It sets like that for a while until it displays a message saying calibration failed.
Anyone else have similar issues or suggest a fix?
I like to do calibration at least once a week if not before every ride.

Couple ideas to try:

  1. Have TR “forget” the trainer and reconnect it
  2. Delete TR app and re-download it
  3. Warm up before calibrating
  4. For some reason, I have much better success if I go to devices from the main menu and calibrating from there instead of clicking devices in the workout

Otherwise, check in with Support.

Mine did that the other day, can’t remember if it was on the BT or Ant+ connection, but the 14.9 speed one failed every time. Connected to my Kickr on the other connection and it calibrated first try.

Also have the same issue with my Kickr. Been that way for a month or more. I’ve just been calibrating with the Wahoo app. It would be nice to not work around whatever the problem is. Have some other bugs in the Windows app too. Guess I should report them, but I’ve figured they are known issues. Hope they can get them fixed before the prices go up!

I have had the same issue. In my case the spin down suggested 24 km/h instead of the usual 36 km/h.
After logging a case and trying the suggested trouble shooting steps still no joy.
I have found if you continue increasing the spin up to the old speed- I think 24 mph in your case and 36 km/h in metric it will work and the calibration will complete ok.
Hope it works for you.

Use the wahoo app on your phone?

Thanks, I’ll try spinning up to the former speed of 24mph and see if that does it. Last night tried forgetting device and reestablishing it to no avail. Also not sure if calibrating in another app like WAHOO or “Z” would be the same calibration for TR, probably close.

Best protocol is always to reach out to support@trainerroad.com. Troubleshooting is very device specific, and the team can help you with any tricks and tips, check for firmware updates that may be causing issues, etc. They’re pros and will be happy to help.

today I spun up calibration to over 24mph and it worked

I’ve been having same problem for a couple months now. Just been doing the spindown through the Wahoo app.

You can keep doing that, it will be fine. Might not be as convenient. Also the wahoo app gives you a measurement ( in seconds).

I’m having the same issue. Just signed up to TR. Calibration failed on PC but was successful on IOS app and Wahoo app. Tried doing ramp test using Win 10 laptop and power was underreporting by at least 50-80 watts. I redid the test on my iphone and it worked just fine. Using Bluetooth. Have Assioma Pedals, tried with it connected and without. Either way every calibration test failed.

1 Like

I have similar issues with my Kickr core calibrating in TR on any device.
The speed does not show on the calibration screen in TR, it stays on 00km/hr. I can get it to calibrate, but its guess work on what speed I’m spinning at. Basically spin up to what I think is 36km/hr then stop wait for spin down and it says calibrated…
When I cant get anything to work, I do a factory spin down through the Wahoo app and that takes time, changing apps, connecting, mandatory 3min spin up to warm the machine up and then perform 2 spin up/downs. I’m guessing that this calibration will transfer over to TR?

Found ANT+ to be more stable, no drop outs.
All devices are up to date with latest firmware’s.

It works, but I just cant get the thought out of my head, is this correct/accurate???

Welcome to the forum group and to TrainerRoad.

  • One common option for any technical issues is to email support@trainerroad.com for direct help. The request goes into their system and gets tracked with constant updates until it’s resolved. Additionally, they have access to all the related app and workout logs that we can’t get here.

  • For general info that might help us and them with support, which exact pedals do you have (Uno or Duo)?