Calibration fail

I have a Kickr core 2019 and I cannot for the life of me get it to calibrate

I can perform a Spindowns in the Kickr app

In Trainerroad and Trainerroad Beta I cannot get it to calibrate with using MacOS or the iOS app.
I am running all the latest firmware and software.
It allows me to get to the calibration screen on TR (sometimes) but then when I get past 30km/hr it doesn’t prompt me or anything to stop and just spins down to 0kpm and then does nothing. No confirmation screen.

I have tried it on ANT and BT but still no luck

Any other ideas? Its doing my nut in and hampering my training!

Since your issues seen to be TR focused, have you emailed them for help on this?

As a side discussion, you only need to calibrate the Core trainer about once every 2-3 weeks. This assumes you are using the trainer in the same room and environment (temp, humidity, etc.). So you can just calibrate with the Wahoo app that seems to work and ignore TR if you want.

My practice for my Kickr is to calibrate one time, every other week. I do it after completing a TR workout. I just kill the TR app, open the Wahoo app, calibrate and then call it a day. That calibration from Wahoo sticks with the trainer and works for TR and any other app using the trainer.

I still think it’s worth checking with TR support, but there is a decent workaround if you mimic my process.