Kickr calibration fail

For several weeks, I cannot calibrate my kicker within the TrainerRoad app. I tried both on the iPad and the android pad and it doesn’t even let me start spinning down,. Has anyone else had this problem ? any suggestions?

Yes, I have the same issue. Plugging it in and out helped sometimes.

tried that…no help

1 Like

Use the Wahoo app. If that doesn’t work then try a factory spin down (also from the Wahoo app). I’ve always calibrated mine using the Wahoo app, not TR, Zwift, or any other program. It also forces me to check for firmware updates regularly, not that they are released all that often.

1 Like

It recalibrates fine using wahoo utility or fitness app? Make sure you have no other devices turned on (phone, bike computer etc).

yes, can calibrate with utility app, and i checked, no other devices…really frustrating because its hard to use the utility app, in the middle of a workout (when the kickr is warm)

Very strange. On the plus side the kickr doesn’t really need calibrating every workout, but hopefully support can figure this out for you.

I had this twice fwiw. The first was solved by connecting Bluetooth not ant+ and a one off other time was because my elemnt bolt was connected.

Ant+ connected? Sometimes have this on my phone. Forget device and reconnect in the TR app and it let’s me calibrate again.

I’ve had the same issue for a few weeks on my iPad. I try to launch the spin down calibration from within the training session, after a few minutes warm up. The tab (?) on the right opens, but there’s a spinning/loading icon and the calibration never loads.

Friday AM, same pattern. This morning (2 days later), after a fresh restart on the iPad, I launched TR and went straight to Devices and started the calibration. That worked fine. For me at least, the calibration won’t launch from within a workout from the Devices section.

I can try that. But ant+ definitely not connected

I’ll try that, but aren’t you supposed to calibrate after the trainer has been “warmed up”??

1 Like