Ant+ services broken after Android Update

For 9 months I’ve used TR on a Samsung Tab A with native Ant+ software. My 3 devices - HR monitor, Kickr and P1 pedals - worked flawlessly as did the TR software. Again there was no need for a dongle.

Last weekend I updated my Android software and now Ant+ has stopped working. I’ve uninstalled and reinstalled the Ant+ software:

  1. ANT radio service
  2. Ant+ Plugins

I’ve found examples on the Ant+ forums of similar behavior but I still haven’t found a solution. All of the devices work with Bluetooth and TR but I’d rather use Ant+ so that I get left/right information from the P1 pedals. Is there anyone in the TR community who has experienced the same thing and solved it?

Since upgrading to 9.0 (Pie), ANT+ is broken on my phone. I don’t see any solutions to this but to wait or downgrade to 8.x (Oreo).

It’s my understanding that I can’t downgrade? Is there a downgrade solution? My Android version that I upgraded to was 8.1.0. and that killed Ant+.

I’ve read that some Oreo updates have broken ANT+ as well, unfortunately…

It depends on your device. I never buy phones that can’t have their bootloader unlocked and custom recovery installed. With a custom recovery like TWRP, you have full control and can install other roms and versions of Android.
Even if the bootloader can’t be unlocked, sometimes you can use the stock firmware recovery tool to install a stock rom but of an earlier version.

What you might check, in case you haven’t already, is that the two ANT+ apps have all the permissions in app settings that they need to function properly.

1 Like

Has anyone contacted yet?

They need to know about this, and that method is preferred for reporting and addressing bugs like this.

It’s not TR app related, but a general Android issue.

1 Like

I did contact TR support but their answer is more about checking to see if Bluetooth works and if the battery is fully charged. This is an Android problem so I thought I’d send it out to the rest of the TR community. I’m an iOS guy so I need help beyond my current capacity.

1 Like

I have checked permissions on both apps:

Ant Radio service says “no permissions required”
ANT+ Plugins Service says “no permissions required”

ANT Radio Service should have a “use ANT hardware”. There is one on my phone, both on Oreo and Pie.

Too bad the real nerds (skilled programmers at XDA forums) don’t use ANT+ for anything. Otherwise these problems would be fixed.
I’m not even sure that the bigger companies know about the issue, and if they do maybe they don’t care.

Post in this thread if you find a solution. I’ll check as well.

My tab A is also broken. I noticed it a few weeks ago after the update and called Samsung. They remoted in and confirmed it was broken. When I asked how far out they thought an update to fix it was, they had no idea. I have a feeling though that they didn’t really report it. I never got a ticket number.

Downgrading to an earlier android version is a pain. I did 3 or 4 versions ago when the new version of Android knocked out my GPS antenna. All I remember is searching youtube videos that showed where to get a downloadable copy of the earlier Android version and how to backup your data, reformat the phone and load the older version of the software. I think it took me about 20 hours of effort but I’m not really a techie. I had a Google phone which was pure Android, you have the Samsung interface which might be the problem and not Android.

Unfortunately on the Samsung Tab A there is no option to go back to an earlier version of Android at least according to Samsung.

Fortunately for me, I had the opposite happen. When my phone crashed at 8:30 pm on the night before a business trip for which I needed my phone, I replaced by LG V10 with the V30. I made the bad assumption that the V30 would support ant+ like the V10 did. Not the case. I contacted LG support and was essentially told they did not support ant+ and it was not their problem. That was January 2018. Much to my surprise, the update last week resulted in ant+ working. I guess LG got enough complaints.

I’m having the same problem after Android update to 9.0.

I remember that on previous android version I had to go to Ant+ radio service in app settings and give permission for the Ant+ radio service to use the ant+ hardware.

Now I can’t give the “app” that permission.

Is there any workaround?

1 Like

The latest update on my galaxy tab has ant+ working again FYI


Thanks for the heads-up. Ant+ is now working on my Samsung Tab A as well.

Interestingly when I reinstalled a fresh TrainerRoad the 3 Ant+ devices that I use won’t connect with regularity even though these same devices used to connect to this same Tab A flawlessly.

My guess is this is NOT a TR issue but a Tab A issue. Bluetooth seems to connect just fine but I only get left pedal data x 2 from my P1 pedals.

I noticed that it wasn’t really working on Sunday when I did the update but I was already running late so I just turned Bluetooth back on and went through the workout. Yesterday though I had some time to look into it and there is still something not right. I can connect my trainer, HR, Speed, and PM to my Edge 520 with BL turned off and they all connect fine. If I try that with the tablet some connect eventually, some don’t connect at all (They are seen in the app, they just don’t finish connecting) I rebooted the tablet just in case but no change. Looks like I was jumping the gun thinking that this might be fixed.

My experience is exactly the same as yours - TR is trying to connect with Ant+ but it doesn’t end up happening. Oh well. Stupid Tab A!

I contacted OnePlus support about the issue and have just been told to update the ANT+ application, whatever that means. The conversation is ongoing. I’m not sure the customer support guy that replied even knows what ANT+ is !

OnePlus doesn’t come with “native” ANT+ as for instance a Samsung Galaxy does.
You need to download an app/plug-in from the Google Play Store to use ANT+ on a OnePlus phone.

I have a OnePlus 6 and have two apps/plug-ins for that ANT Radio Service and ANT+ Plugins Service.
Don’t know why I have two, but those are installed on my OnePlus