ANT dongle connection problems

Hi all, I’ve been using the Wahoo ANT dongle with 3’ extension for awhile know to pair with my Wahoo KICKR and Stages LR dual-sided powermeter. I keep getting dropouts every 10-20 minutes in which the power would then drop dramatically (in erg mode) and not recover for 20-30 seconds and more recently, I noticed after moving my trainer/setup to another room that the dongle would just lose pairing with the KICKR all together, which has become extremely frustrating. The connection is quite fragile and even touching the USB extension cable connection where it connects with my Macbook adapter leads to complete drop outs of the ANT connection requiring me to stop my TrainerRoad workouts and unplug/replug back in the USB connection. I’ve read that getting a longer extension cable may help with this so that the ANT dongle is directly next to the Wahoo KICKR? Before I invest in this, wanted to get people’s opinions/recommendations on what to buy, etc.

Thank you all.

1 Like

Hi there,

If you’re running into dropouts, reaching out to our support staff at may be a good option - they’ll do their best to help you out!

In regards to ANT+ dongles and extension cables, I’ve seen all sorts of solutions and setups, but nothing seems to be “one size fits all”. I’ve seen an extension cable improve things, I’ve also seen an extension cable make things worse. Sometimes getting the ANT+ dongle closer to the device can improve the connection quality, while other times having the ANT+ dongle plugged directly into the USB port can improve things. An ANT+ dongle from one manufacturer will likely behave differently than one from another manufacturer, and sometimes two ANT+ dongles from the same manufacturer will behave differently.

We have generally found that Bluetooth provides a more stable connection than ANT+. We natively support Bluetooth on all platforms, so I’d certainly suggest trying it out if you have the option.

I’m sure that others will chime in with their own opinions here as well. :slight_smile:

Sounds like you might want to try a new extension cable or a different USB port on your Macbook. If it’s that loose when plugged in, you’re probably not getting a good connection.

I use a 1m USB extension w/a Macbook Pro. The ANT+ dongle currently sits right about under the front hub. No problems w/picking up signals from HRM, bike PM, or Neo.

You might want to consider your current WiFi setup as well. If you’re using 2.4Ghz WiFi, then move to 5GHz. ANT+ is in the 2.4GHz spectrum. By switching to 5GHz, you reduce or eliminate a source of interference.

Do you use the Macbook Bluetooth simultaneously? I found that on my older Macbook Pro, that typically caused issues. As soon as I disabled Blutetooth, no ANT+ problems. I never quite figured that one out. Bluetooth also uses the 2.4GHz spectrum. Interference? Antennae placement/design? Internal hardware interference due to inadequate shielding? I don’t know… But disabling Bluetooth solved it. W/my newer Macbook Pro, I have ANT+ (TR), Bluetooth (wireless earbuds), and WiFi (streaming music) all running w/out issue.

1 Like

I had a month of trying to get to the bottom of some dropout issues.

Tried different ports, different extension cable, different dongle locations on the floor. All to no avail.

Got in touch with the TR support team and they were as helpful as they could be. Suggested I try to reduce the possibility of interference from other sources, such as Bluetooth, wifi, fans, cordless phones etc. I did a couple of workouts with no fans, no wifi, no Bluetooth headphones, all to no avail.

I analyzed the Wi-Fi traffic in my house and it was crazy… I live in an apartment and can see at least 15-20 different Wi-Fi detected in my pain cave. TR suggested that I try to change my Wi-Fi frequency and channel. Unfortunately I am using a Google mesh network, so I cannot isolate the suggested 5ghz network, not can I specify what channel I broadcast on.

It was starting to look grim.

Until I decided to change my dongle. I bought a new ANT+ dongle and an BLE dongle in case I needed to go down the Bluetooth route. However, the new ANT+ dongle did the trick and dropouts have now become a thing of the past. Maybe some sweat got inside the old one, but it seems it was Giving a flaky connection.

Happy days again.

Oh, a final thought. Using the Wahoo app, I tested where the strongest ANT+ signal was on my Kickr. (gen2). I got a slightly stronger signal with the dongle right behind the flywheel. I settled for a compromise as shown in the image below. A 3m extension cable allows me to get the dongle here where it can detect the broadcast from my Kickr, my Assiomas and my hrm:


I’ve got random 3-4 ANT dropouts per 1 hr session. Switched to Bluetooth but here things are even worse as it suddenly freezes the data read from my wahoo kickr core and tickr, or it just stops reading power/cadence data from the kickr core and no way to recover even reconnecting.
This all started a few weeks ago.
Happens in stable and beta version. 2 different bluetooth devices.

I’m sorry to hear that you’ve ran into connection problems over both Bluetooth and ANT+. :frowning:

I’m not well equipped to troubleshoot those problems here, so your best bet is going to be reaching out to our dedicated support staff at If you could provide them with as much information as possible, they’ll do their best to help you out.

I’ve been experiencing ANT dropouts (maybe 3-4 each session) where the trainer completely disconnects and I have to pair it again. It has happened on every workout for the past week when it has been working perfectly for years.

The strange thing is that everything looks the same as always: Macbook Pro, extension cable, ANT dongle, trainer, distance, room… could it be something related with the latest TrainerRoad (beta) releases?

Of course it could be something else, but just wondering if anything related with ANT communication has been changed recently on the OSX app.

I think I may have “fixed” the issue. Did Baxter today and had my usual 4-5 dropouts including a handful of complete disconnection of the Kickr. I was dinking around with the Bluetooth/ANT ON/OFF and turned back on the Bluetooth at end of the session. Subsequently, did an easy 30 minutes where the Kickr was connected via Bluetooth while the powermeter remained connected via ANT - had 0 dropouts during second session. Time will tell with longer workouts if I experience no further dropouts with Bluetooth for Kickr and ANT for powermeter (I have the Wahoo app also specifying to control power with ANT powermeter).

With the help of this forum, I recently started connecting my Stages LR powermeter to TR via ANT and not Bluetooth as I found out that only ANT results in dual power measurement while Bluetooth only reads from one arm. This change resulted in my RPE indoors being much more in line with my power numbers outdoors, which was awesome. I think in order to consistently connect to my powermeter I disabled Bluetooth all together, which subsequently made TR connect to the Kickr via ANT as well and hence the start of all the dropouts.

I’m wondering if by choosing to have the Kickr connect to TR via bluetooth now and not ANT, it shouldn’t be affecting my power numbers given TR is still reading my powermeter via ANT, correct? I suppose I will find out as I continue to do intervals and as long as the RPE remains the same as before… but just wanted to corroborate since I recently did a ramp test with ANT connections only to the powermeter and Kickr and don’t want the accuracy of my efforts thrown off now by switching the Kickr to bluetooth while keeping the powermeter on ANT.

Thanks, sorry for the long winded explanation.

Dropouts are the bane of my …

If I use an Active USB cable with the Garmin dongle. I have the cable struck below the Kick’r Desk on the right side of the computer/bike. I have noticed that I get better reception if I keep the dongle in mid-air and not touching the floor, desk, mat, etc.

My ANT+ connection to TR via a 2018 MBP is stable for 99% of the time. I do see some dropouts during the workout but it is from the Wahoo Tickr Fit. I try to keep my eye on the little box on the UI that shows the active number of connections. The minute I see it change, I pause my workout, click on the little box, forget and repair the missing device, and resume the workout. Everything is stable for the rest of the workout.

I’ve given up using Zwift with ANT+ not stable always issues. Everything there is a Zwift release, I have to delete the app, the data folders, overwrite where the files were stored, reboot. I need to do this 3 - 4 times before ANT will work again.

I’m also carefully where I place my iPhone and wireless headphones, that I make sure they are on the opposite side of the computer/bike from where the ANT+ dongle and USB connections.

I’ve also disable WiFi on the MBP and use a CAT-5 cable, just so the MBP is trying to process one less signal. (The room is still flooded with various signals).

I think ANT+ and BTLE are in the 2.X range so a 5.X wireless phone or other devices, will not outside the conflict range. Make sure your WiFi is using 5GHz to keep it out of the ANT/BTLE frequency range. Also, if you use wireless phones, check their frequency.

There have been days, where I just want to hard wire everything to the MBP.

I have been experiencing the SAME problem with the same set-up you describe: Macbook Pro with the same extension cable, ANT dongle, trainer, distance, etc. that I have used for 2 years. I have had dropouts three times this past week and have had to get off the bike mid-ride and work for several minutes to re-connect.

I also have to wonder if something in the latest TR updates has caused this problem

I’ve been experiencing ANT dropouts (maybe 3-4 each session) where the trainer completely disconnects and I have to pair it again. It has happened on every workout for the past week when it has been working perfectly for years.

The strange thing is that everything looks the same as always: Macbook Pro, extension cable, ANT dongle, trainer, distance, room… could it be something related with the latest TrainerRoad (beta) releases?

I’ve just updated the application (I’ve noticed they are releasing a new version once a week, at least for the beta channel) and I’ll try again on today’s workout. If it keeps happening I’ll contact the technical support to see if they can help.

I’ll post updates if I make any progress

ANT is the worst! I suffered for 16 months with the problem. I too wanted the computer connection. i had a garmin ant HR monitor, shimano ant power meter, PC laptop and a Tacx Flux. Ended up switching to the iphone app, bought a wahoo hr bluetooth monitor and have ditched connecting to my power meter. In the end, i’ve consistently received a 10 watt difference between my power meter and trainer. I could use this to make informed decisions about my training and performance. I ended up realizing that the only reason i’m doing all this is to get stronger so just choose one data source and train hard.

moral of my experience- blue tooth just plain works better and TR is reluctant to support it. I’m not sure why- perhaps because of all the environmental variables. Perhaps there is something within the coding. I don’t understand the electronics and physics behind it, but bluetooth just seems to work with TR better. Any move to bluetooth you can do- the less frustrated you will be and the more you can focus on getting faster.

btw, i abandoned a $75 ant dongle for iphones, an iphone pin converter, and a heart rate monitor to get to where i’m at now. Not cheap, but my happiness is definitely improved.

Old thread being reinvigorated. I think I’ve found the source of my problems with ANT+ dropouts and general odd behaviour. My Bluetooth headphones. How I didn’t realise sooner I’ll never know. Only found out today when I decided to watch a YouTube clip whilst listening with wired headphones. Switched to the Bluetooth after that to listen to a podcast and bam. Problems with trainer connection started. Back to wired and it all went away.

Real question is though, how can I still use my Bluetooth headphones whilst in the turbo? My wife has the same headphone type but a different turbo, and zero problems.

Use a tacx ANT+ dongle positioned next to the turbo, Bluetooth switched off on the laptop. Tacx flux 2 (wife has an elite suito). Power matched to Garmin vectors. If I get a drop out it’s the turbo, not the pedals or HR strap.

1 Like

Hello everyone. Also did a fair bit of troubleshooting the last few days. For MacOS, especially the MB Pro, with their “fancy USB-C only interface”, ANT+ is problematic (dropouts every couple of seconds in my case). In order to train properly whilst using my Macbook, Bluetooth is the only option here. My assumption: USB-C adaptors are the ones to blame. Don’t know the exact inner working of them, but couldn’t this be some kind of congestion in the adapter which is causing the ANT+ dongle to Macbook transmission to fail on a regular basis (any electronics/hardware specialists on this forum?). I use a USB-C dongle from Amazon (not a cheap, not expensive,

I think I isolated my problem to this reason, as on a Windows laptop, in the same environment, with the same ANT+ dongle, the connection is very stable. Maybe it is just my UGreen USB-C adapter, but it is very annoying.

If I find some time for it, I will further troubleshoot my Macbook stability issues (computer scientist over here :wink:)

I don’t have experience w/any USB-C adapters. However, I would recommend getting a USB extension cable for your ANT+ dongle. Getting the ANT+ dongle closer to your trainer and/or bike PM is a good thing and typically resolves drop-outs as you are describing. Odd though, that the dongle is fine w/Windows. Still, the USB extension is worth a try.

I believe those USB adapters need drivers. Perhaps double check that you have the latest drivers installed?