Xplova Noza S compatibility issues… or not perhaps

Hi, I guess this is a question for the TrainerRoad tech peeps unless anyone else has the answers….

What is the issue with TrainerRoad and communicating with the Noza S via Bluetooth?
It seems every other app is ok but not TR?

Even when connecting via Ant+ (to my iMac) why does TR not want to complete a spin down calibration?

I don’t know if having Bluetooth on while being connected by Ant + is affecting it, but seeing as my keyboard and mouse are both Bluetooth, turning it off to prevent it pairing isn’t an option

I really want to have TR on my phone/iPad so I can watch Netflix on my iMac but that seems even further away from possible. :slightly_frowning_face:

Longterm TR user and big fan, really want this to be sorted as I’m not going back to my stupidly noisy Kickr!


Hey there! Sorry to hear about the trouble you’re having with your Xplova Noza trainer. We don’t officially support that brand of smart trainer, so we can’t guarantee it will work perfectly with TrainerRoad. That said, there’s still a few things we can check:

  • Bluetooth devices can only pair to one device at a time. If any other application, head unit, computer, or device is paired to the device you’re trying to pair, TrainerRoad will not be able to “see” the device. You will need to make sure that your device is unpaired from every other app/computer/device etc… before attempting to pair it to TrainerRoad.
  • Download the Xplova app and check for any firmware updates.
  • Wireless devices such as 2.4 GHz routers, wireless speakers and wireless mice may interfere with the Bluetooth signal. ANT+ and Bluetooth use the 2.4 GHz band. Try moving any other wireless devices a couple of feet away. If you suspect your router to be interfering, you can change your wireless channel.
  • Do your best to ensure that your computer has the most direct line of sight possible to your sensors. Simply put, the closer and more level your devices are to your phone or computer, the better readings you will get.

It sounds like you were able to get the trainer connected via ANT+, so you may be able to use it that way! Based off of other support tickets we’ve had from other athletes with this trainer, that may be the preferred method of using it. When athletes were able to pair it via Bluetooth, it only paired as a power meter, and could not be used in ERG mode. Other athletes seem to have had better luck using this trainer in ERG mode via ANT+.

Finally, if you’re having trouble calibrating the trainer using the TR app, try calibrating it using the Xplova app. The calibration data gets stored in the trainer itself, so it will carry over to TR when you start your workout.

Hope this helps! Let me know if you have any other questions.

Thanks for the quick and detailed reply!

First attempt at setting it up this evening.

It will connect and pair by both, no problem, and displays a power reading.

It won’t perform a calibration via Bluetooth, it will via Ant+ but won’t give a result, just sticks on ‘calibrating’.

But if as you say I can calibrate via the Xplova app I’ll try that.

From what you’re saying about Erg mode, which I use all the time, it seems Ant+ is the way to go, but do you know if it pairing via both at the same time affects it?

As I say I can’t turn Bluetooth off and don’t seem to be able to prevent it from pairing.

Finally, any ideas about connecting to iPhone/iPad via Ant+?
The same Ant+ dongle that works ok on my iMac doesn’t seem to want to pair it with my phone.

Thanks again.

Got it – if the trainer does connect via Bluetooth, it could be worth trying to see if it will run in ERG mode! If not, sounds like ANT+ would be the way to go.

To avoid double-pairing, you could try turning off Bluetooth on your Mac or iPhone/iPad temporarily, connecting the trainer via ANT+, and then turning Bluetooth back on. Alternatively, you could also navigate to the Advanced Settings menu in the TR app and disable Bluetooth for the app itself.

As for using ANT+ on your iPhone or iPad, a good starting point for what you may need can be found in this article. Some of the recommendations are marked as “unavailable” now, but it should give you a good idea of what you need to look for. It may be possible that you need a new or different ANT+ dongle for your iPhone/iPad if it won’t connect.

Thanks again, I’ll do the app calibration and then give Erg mode a go tomorrow via both and report back.

Going back to the phone connectivity, I read that article earlier, was there a reason why it was specifically the Wahoo dongle that was recommended at the time?

They have discontinued the 30pin connector one some time ago. It doesn’t look like anyone has yet made a direct to lightning on.

I don’t fancy working through a load of usb Ant+ dongles by trial and error if there is something specific to look for in any specs.

I haven’t looked for a direct to usb-c one for my iPad yet through, I don’t know if they exist?

I’ll also try a usb to usb-c adaptor.

I had similar problems with my Xplova Nova S, using Wahoo Systm. It worked fine with Zwift(box was marked Zwift compatible) , but did not report power to the SYSTM app or my Elemnt Bolt computer. I contacted Wahoo technical support and the answer from them was that they were already aware that the Nova S does not use a standard Bluetooth communication protocol (its not listed in their list of compatible trainers) and that they would have to recode the app to recognise this specific trainer and communicate with a compatible protocol.

I contacted the retailer to complain that it wasn’t fit for use, they arranged collection, I got a full refund and I bought a Jetblack VOLT EMS instead, which has been flawless, but has a smaller flywheel so the road feel is not quote as good as the NOVA S.

1 Like

As long as I can get it working in erg mode on TR I’ll be happy.

Not really bothered about it communicating with anything else.

Well, update number 1

Just done a spin down calibration on the Xplova app on my iPhone via Bluetooth.

Followed that with a test run of TR on my phone, via Bluetooth, in Erg mode, and it seems to be communicating just fine…

I change gear/cadence the power fluctuates and finds it’s level.

I adjust the intensity manually and the power demand goes up, back it off and it comes down and the trainer finds its level again. Screenshot attached

So fingers crossed it seems so far that the incompatibility fears may be overblown, and it’s just the calibration exercise that doesn’t want to work on the app via Bluetooth, and if that is the case then for the £299 that Wiggle currently have it on sale for it’s an outrageous bargain.

And with that I’m going to get changed and try a workout.

What this new turbo has revealed is just how noisy the Kickr is, how seriously quiet this one is, and how much it sounds like my old turbo bike needs a damn good service that I couldn’t hear before! :joy:

Did anyone figure out how to make ERG mode working? Even my Karoo 2 can control Xplova NOZA S in ERG mode.

My last post tells you what I did and it works just fine.

I’ve had a Noza S for nearly 12 months now and never had any issues with it communicating with TR in ERG mode, including the spin down calibration. It worked straight out of the box

1 Like

Thanks guys, so after your comments gave it another try. Turns out it is not working on Windows. When connected to the phone, working just fine, small problem on low and high cadence with standing drills. Anyway happy to finish first training.

1 Like

Yeah, I’ve never used it on Windows - I only run TR workouts via the Android app