TR tries to pair over Ant when already paired over bluetooth

So if I have TR paired to my trainer (2018 kickr) over bluetooth why does it try to pair over Ant too? Shouldn’t it know it is already paired to a trainer so not try to pair over Ant+? (this then seems to cause a signal issue with the Bluetooth pairing cause it then switches to Ant)

I’ve tried contacting support. The person handling the issue wants to troubleshoot the Ant+ signal and acts like TR is working correctly. To me it shouldn’t matter the quality of the ant+ signal from the trainer. Right?

Just to provide more background on my problem the original issue was TR was having connection problems over Ant+. That was weird too in that I run Zwift at the same time as TR in windows 10 and Zwift going by https://zwiftalizer.com/ has a good signal. Per TR support I switched to Bluetooth and that almost completly solved the connection problem but support is still showing dropouts cause by trying to pair to the kickr over Ant.

I’m using a powered USB hub and USB extension cable to get the ANTUSB-m stick behind my crank closer to the kickr

The inelegant solution to this (which many of us employ) is to pair Zwift via ANT+ first, then open TrainerRoad. This is my standard, and as long as I don’t screw with it, everything is clean. Zwift desktop remembers your last pairing and prefers that, so it’s automagic every morning… and TR doesn’t seem to worry about ANT+ if Zwift is using it. Lord help me if I accidentally open TR first!

You can also disable BLE on TrainerRoad and force it to connect via ANT+. I do this when I want to pair my bluetooth headphones to the computer to listen to a group workout or whatever since my cheap headphones interfere with TR’s trainer control signal.

But my daily solution is the first paragraph. Easy peasy.

My power meter is ant only and have two ant sticks so both apps have access to ant. Had Bluetooth disabled completely on the laptop before getting the to connect to the trainer over Bluetooth

If you are just using Zwift for the entertainment, why not let your trainer connect to Zwift for power and cadence via Bluetooth, disable Bluetooth on TR and force TR to use a single ANT stick to connect to the trainer and your power meter? Then the same thing applies, just open Zwift first, get the Bluetooth pairing for your trainer connected to Z, then open TR and use ANT there?

I wouldn’t think you’d need to use two ANT sticks for this setup, but perhaps I’m missing something. Seems like you wouldn’t need to connect your power meter to Zwift at all with a Kickr 2018.

What trainer do you use? I’m wondering if this is related to the trainer since I don’t have this problem regardless of which I connect first (I actually usually connect TR first via Bluetooth on my Mac then Zwift through Ant+ on my Windows 10). For reference I use a Stac Zero Halcyon trainer.

The major difference in our setups is that I’m connecting Zwift and TR via the same machine (Mac). I run:

  • Kickr Core
  • Vector3s
  • Tickr HRM

All on a 2018 Mac.

Zwift -> ANT+ USB dongle; TR -> BLE. That’s my normal setup.

If I’m doing a group workout and need headphones connected, I can run TR via ANT+ with BLE turned off in TR (and if I want Zwift running on the side I’ll just pull it up on my iPad). Both of those setups are seamless as long as I remember to connect them in proper order (Zwift first, then TR).

1 Like

I’ll try this. Will this work if I have one PC with a BT and ANT+ adapter and one PM?

But this is super frustrating especially when you have exactly 1.5 hours for a workout and then spend 25 minutes finagling with all the pairing. I really wish one could just sync the TR workouts into Zwift

It should work.

I’ve had more success lately running Zwift via the iMac (Ant+) and TR via my iPhone on BLE. Both paired to my power meter.

This has been faster and less hassle to set up lately even though it involves a second device.

How do you actually turn off BLE in TR? Or do you just mean, it won’t see it because Zwift already has it?

I’ve also been having connection issues lately that I can’t seem to squish, and I’m curious if it has to do with both ANT and BLE…

On the Mac Desktop app (don’t know if it’s the same on PC), you click “Settings”, and then scroll all the way to the bottom and toggle “Disable Bluetooth”. It says it’s “not recommended”, but TR support crew has told me when troubleshooting my setup that many users who run both disable bluetooth for TR and let ANT+ run the show with success.

2 Likes

Awesome! Thanks. I kept trying to click the Bluetooth On or ANT+ On on the devices page