TR doesn't detect Native Bluetooth 4.0?

Despite my best efforts, TR doesn’t seem to recognise that the native Bluetooth is turned on (and paired to my phone). On ‘Pair Devices’ page, it says ‘Bluetooth off’ and ‘ANT+ off’. Clicking on Bluetooth brings up ‘connecting Bluetooth’ after which nothing happens. Using a 2013 Dell XPS 13 9350 with Windows 10 (preinstalled on purchase). Bluetooth device reads as 4.1 on Device Manager. Bluetooth is paired to other devices like my phone. Running most recent update of Windows 10. Can’t seem to find anything in help or support relating to this hence this post. Kickr is paired to iPad and iPhone no problem. Any help is much appreciated.

Contact for best help with this issue.

Actually I have the same issue with my Lenovo Yoga, but eventually I gave up and continued using the Bluegiga dongle. If you get a solution to this, I’d be very pleased if you let me know, too.

There is definitely a problem with TR and bluetooth. I’ve been using TR with the Inside Ride SmartPower for almost a year, then a few weeks ago it would no longer connect to TR through iphone. Inside Ride confirmed there’s a rash of complaints about TR not connecting through bluetooth anymore, and they have been trying to get TR to respond but are getting no answers. Meanwhile I’m either using ANT+ to connect or just spending more time on Zwift, which has no problem connecting with the SmartPower.

1 Like

After uninstalling and reinstalling both TR and the drivers, it now finally recognises Bluetooth however it’ll only pair with my Tickr and Cadence sensor! I think this is more a problem with the Kickr now as pairing issues are fairly common if you do a quick Google. However for those of you strugggling, it might be worth reinstaling TR and seeing if that helps.

I randomly have this issue, not sure what to do. I can pair with my phone but not the computer.

Please shoot us an email at and an agent will help you work through this issue.

We look forward to hearing from you!

I was unable to fix the issue with tech support, suggested I use Ant+ or continue using another device. Is anyone else experiencing this issue?

Here is a quick run-down of where I’m at:

  • All BT enabled devices in the house are turned off.
  • Hammer H1 shows as a device available to pair in the windows menus (but not pairing with native BT)
  • BT still shows “off” in the trainer road app.
  • I can plug-in the ANT+ dongle and that turns-on and pairs as designed with the TR application.
  • Running Win 10.8, R&R’d BTLE drivers