Wrong power with smart trainer

Hi all.
I recently got TrainerRoad. The soft is great. But for my first use, the power is always wrong. Can’t go up 100w, or other moment , under 160w.
I’m using a Bkool smart Pro with a Garmin cadence sensor. I’m using the smart trainer’s power meter.
My setting are currently ERG activate and Powermatch auto.
Smart trainer AND smart trainer’s power meter are connected on trainerroad. I’m using on Mac.
Any ideas ?
Thanks guys!

I think having the trainer connected with two profiles is causing the TRAINER profile to fight with the power meter profile as it’s allowing you to select power match. Power match is only for use with an on bike power meter.

Connect with only the trainer profile and see if your problems go away.

If that doesn’t help then support@trainerroad.com

Thanks for your return. I actually did yesterday but it doesn’t work…
should I let ERG mode and Powermatch in auto?

As long as you have no power source selected then powermatch setting shouldn’t matter.

Additionall can you make sure you have sufficient tension on the wheel (check the trainer manual for this), that it’s inflated properly, and that you are in the small ring and about half way down the cassette.

  • Not relevant to his trainer since it is “gravity” that presses the wheel and roller together.
  • That may not be appropriate for this trainer. It may be necessary to use higher gearing. It is important to test at extremes to see what impact it has on power.
1 Like

So, if I have to resume.
Need to check the wheel pressure
Don’t matter for ERG mode and Powermatch
Only select the smart trainer to paire with trainer road and not the smart trainer’s power meter
I will check this afternoon. If it doesn’t work, I will try with my own power meter on my outside bike.

You only need to connect the trainer once, not twice. You should have connected the trainer, cadence, and HR if you use it. You don’t need to pair the power meter if the trainer separately, nor do you need to use powermatch unless you’re using a power meter that isn’t in the trainer

Ok, ‘cause when I start the trainer, I see « Bkool smart Pro2 » like the smart trainer, and an other appareil which is « Bkool smart pro2 » like the power meter.
I only paire the smart trainer so, that’s it?


Right, I would try that. When I used to use my trainer’s power meter I only paired it once

Ok. It’s work!!
My wheel was under pressure, and I paired only the smart trainer.
My power is lower than outside but it’s normal I guess, it’s less accurate. But it’s now « ridable » :)) I will check with my own power meter to see the difference. Thanks all!

1 Like

Glad to hear. Indoor power being lower is totally normal. Keep us posted if anything else goes wrong

Indeed. I’ve put my power meter and it’s really better. No mode erg and no powermatch. It’s now perfect :slight_smile:

1 Like

Hello all!
real test today and it seems strange. I did a workout with erg mode and powermatch disable, still with my own powermeter. But I did all the workout on the strongest gear and I feel easy, like very little resistance. Is that normal? To the point where I need do sprint @450w for example, it was impossible ‘cause I had too much velocity. Maybe it’s the erg mode?