Just cannot get powermatch to work

I’m getting extremely frustrated with TR powermatch. It just does not work.

I’ve tried it on the beta iPhone app and the standard iPhone app but neither work properly.

I’m using a tacx vortex smart trainer and a 3rd generation stages left crank.

I took a snapshot of an instance where the trainer will just not balance up with the power meter. This was 1min 2sec into the recovery interval and you can see the numbers are WAY out.

This is my fourth TR workout in a row that I’ve had to quit because of this.

Is this a bug?

I don’t think powermatch is the problem here, as powermatch just manages the difference in watts reported from your PM and trainer and equalizes them. I’d suspect something with calibration, the mode you’re in, or the trainer. I’ve run into some issues with wheel on trainers and power meters, using ERG mode and powermatch:

  • For the first minute or two of a workout it’ll start pretty high and work it’s way down to match
  • At lower watts, during a recovery valley the average was supposed to be 101 watts, recorded a 128 watt average, and was consistently up the whole time.
  • Changing RPM’s, it feels like when you change RPM it lags so it doesn’t overcompensate, but also it seems like if you change RPM a lot it doesn’t really know what to do and it can yo-yo pretty hard between too much and too little resistance

What I’ve done to try and alleviate some of these things are:

  1. Keep a steady cadence.
  2. use a different gear, it could be you’re using a gear that just can’t make 84 watts regardless of how low the resistance on the trainer is. Easy way to test is to turn off powermatch and just run off the trainer
  3. Calibrate your PM and Trainer
  4. Try turning off ERG mode (or turn it on) and see if that helps things.
1 Like

Thanks for this. I’ve done steps 1 to 4 during every workout that I’ve had issues and it’s made no difference.

I wonder if it could be a faulty trainer?

Are you changing gear? The vortex has very narrow operating ranges relative to wheel speed, especially at lower powers.

1 Like

It could be, you could disconnect your PM and use virtual power and see if it’s happier.

Also, if you tap the ‘x Paired’ box in the bottom right, it’ll bring up both the PM and Trainer, and you can see the watts as you pedal, it’ll pause your workout so do this as a test, and you can see if either your PM or Trainer are reporting wacky numbers.

Also if you wanted to get fancy if you ride with virtual power, and hook your power meter up to your gps head unit, you can do your own ‘virtual power matching’ and get more of an insight into what’s happening.

Another couple of thoughts, are you new to indoor training / new to TR but have used something else prior, is your trainer new, power meter new?

Also if you’re new on the trainer, are you using a trainer tire or road tire, is your tire pressure towards the max? I’ve found that a lower pressure tire (also not using a trainer tire) can throw off the trainer and make power higher (ymmv)

1 Like

Hey @GeorgeAnderson,

I’m really sorry to see that you have not been having good luck on your last few workouts. We hate to see this kind of frustration-inducing issue, and we’re going to do everything that we can to set things right.

The most likely cause of this issue is using too large of a gear with PowerMatch. The increased inertia of the rear freewheel makes it harder for your trainer to execute ERG commands, and then combine that with the added processing required for PowerMatch, and you have the potential for some technical miscommunication.

We recommend using a very easy gear when using PowerMatch. You will certainly want to use your small chainring, and then use the largest rear cog you can before you start to sacrifice optimal chainline.

I’d recommend trying this out on your next ride to see if it mitigates the issue.

If you still experience the same problem, I would recommend disconnecting your Power Meter, and conducting a workout with only your Tacx trainer paired. This will help us to eliminate the possibility of a hardware malfunction with your trainer.

Please let me know the results of these tests, and if you continue to have issues I will have a Support Agent reach out to you via email to troubleshoot further :slight_smile:


Thanks for this advice @Bryce

I’ve always used the large chainring. If I have to start using the small chainring does this mean that I will have to retest my ftp again before I do any workouts using the small chainring?

I also have a Vortex and this definitely looks like a “wattage floor” issue rather than a powermatch one. Basically in a given gear there is a minimum wattage the trainer can go down to. The higher the gear the higher the wattage floor.

I usually ride my intervals in a 50-13 gearing which works well. However, if I don’t change down to the middle/small ring for the recovery my watts don’t go lower than 150-170.

@GeorgeAnderson I’d try switching rings in the recovery intervals and see if that helps things out. No need to retest as you’re still doing the work intervals in the same gear combination.

I’ll give it a go but I’m using the same equipment and gearing as I’ve used for months and never had an issue until now.


I’ve tried everything you suggested and I just cannot get it to work anymore.

It was working previously but isn’t anymore.

Another ditched TR workout today.

I can’t carry on like this as I’ve not done a decent workout in over a week.


Are things working correctly if you don’t use powermatch? Curious if you unpair your power meter and connect only to the trainer if things work as expected or if you see the same behavior

I tried disabling my power meter and things worked perfectly until TR tried to change the watts for an inerval and the actual power would not settle down to the target power. It was sitting at 300w against a target of 240w.

Everything was working until last week.

So…things don’t work at all. You experience failures both with a direct single pairing to your trainer and a powermatch setup with a pairing to both the trainer and the power meter.

I’d defer to @Bryce or others on the TrainerRoad crew, but would suggest you set aside powermatch and try to get things working with the direct pairing to only the trainer and then add the complexity of powermatch to the equation.

Don’t know what would’ve changed in the past week that could impact your setup - and it sounds like you’ve done all of the following - but update the firmware on the trainer, then close all other applications on your phone to ensure nothing else is battling for connections with the trainer, unpair the power meter and the trainer in TrainerRoad, repair only the trainer, do a spindown, and try a ride in an easy gear.

Could be any number of things - although the earlier responses about power floors could be relevant it also could be increased interference due to something changing in the WiFi realm (neighbors bought a new router, whatever) or any number of other things.

Basically - remove the variables and make sure you don’t have multiple devices or applications fighting for control and see if you can reproduce the problem


Just a note on this based on my own experience, albeit with a different trainer (Kickr 2).

I found that sometimes the trainer would “ignore” a change in watts and would stay at 300 when I was supposed to be resting at 140. What eventually solved the problem was connecting to the Kickr via Bluetooth instead of Ant+.

May not be the cause in your case, but worth mentioning.

Otherwise, I can’t add much to the solid advice @trpnhntr offers.

1 Like

Thanks but I’m only using Bluetooth.

Done all the things you mentioned both before and during the ride today with no effect.

I’ve just tried Zwift as I have a account and everything went smoothly. No power issues at all.

Hey George,

I’m really sorry for the continued difficulties. I am going to have a Support Agent reach out to you via email to take a closer look at your log files and try to decipher what is going on.

From what you’ve described, this is not an issue with PowerMatch (since it didn’t work even when PowerMatch was disabled), but rather, it is an issue with the communication between TrainerRoad and your trainer.

While you wait to hear from Support, I’d recommend ensuring that your firmware is up to date using the Tacx app.

Sorry again, we hope to get this resolved ASAP.


That would be fantastic thanks as TR is far superior to Zwift


I used to run the same set up as you, with similar issues. Following the TR support advice (as already mentioned above) helped a lot.

I learned that I had overestimated my FTP with the Vortex (before Stages crank PM) by using my biggest gear (42/11 - I am on MTB 3x9 setup). After adding Stages PM, switching to my middle chainring helped PowerMatch ‘feel’ better and work better for me.

There were still occasions where I would sail off the end of an interval and the Watts would remain high - I learned to back off the pedals a lot to get the system to react and follow the power down. Going up big steps in power I would make sure my Stages got the message with some unequal pedalling.

Reading around the web, I think the Vortex has a narrow operating range of power vs wheel speed. I guess this makes for a challenging control environment!