ERG mode not working with PowerMatch

Hi, have recently returned to TR for indoor workouts. I have both my power meter and smart Trainer connected via Devices with Powermatch activated. Also activated is ERG mode but today when I did a simple endurance / interval session for 45 minutes there was no trainer resistance so had to change gears to match power targets. With ERG mode activated does anyone know why the trainer wasn’t being controlled by TR software or does it have something to do with Powermatch? Should I only do ERG mode workouts via the smart trainer and not connect the bike’s power meter? Thanks for your help.

If you haven’t simply toggled ERG off with the keyboard by mistake , the ‘T’ key (If you are using Android iOS thats unlikely) I’d contact , its sounds like a Bluetooth hogging problem if it not a toggle and they’ll help you there.

1 Like

Thanks, using an IPad (no keyboard) so no accidental key hit. I did check Settings through the workout & ERG mode clearly selected. I thought that maybe the bike’s power meter was over riding the Smart Trainer’s ability to control the workout via ERG mode.

ERG and PowerMatch are compatible and should work to fine. I suggest emailing since they can dig into the logs for the ride and really see what happened behind the scenes.


Hey @adamreed,

It looks like support has got you covered. :+1:

Just shout if we can help with anything else!