What the heck is going on with the Mac Software!

Just spent 1.5 hrs doing an workout that I thought was far too easy. Just set up in erg mode and let my iPhone run thinking the numbers were a bit low. I get back and check the web account and…WTH!

Looks like after opening the Mac desktop version of the software earlier my account details have been reset the the values it was using the last time I opened it - not from my online account - worse its updated my online account and my FTP and weight!!!

I really don’t want that happening again - pretty much puts a 1.5hr workout down the pan. I’ve now manually changed it back and will have to make up the workout tomorrow I guess.

I use a Mac and haven’t had any issues like you’re describing. I think this one is best handled by support@trainerroad.com. Shoot them an email and I’m sure they’ll help you out.

3 Likes

No - not paying to beta test software or call support to run tests.

If I sign up to a beta then I understand the limitations (I’ve worked in software development)

I’m paying for a service that shouldn’t screw up my training. This sort of thing should never happen. I am now feeling extremely nervous about opening the software on anything but my iPhone.

Support is there for a reason. What you’re describing is really odd behavior. I’ve used mac and iPhone for many workouts without issues so I suspect there is something going on with your specific setup, usage or conditions. So, I think it’s unlikely that you’ll be able to diagnose the problem effectively in this forum. TR know their product best, so my advice to you is that if you’d like the issue resolved, they are probably best to help you out.

2 Likes

Hey PT1,

Firstly, I’m really sorry to hear about the issue you experienced that wrecked today’s workout :pensive: Our goal is to make you faster, and issues like that certainly don’t help us achieve our mission.

Now onto the issue at hand. This is actually not something that we have heard of before, so we appreciate you taking the time to report it to us. Since this is not a common issue, most likely, this is is a one-time error caused by some type of miscommunication between the App and Web.

What verison of the Mac and iPhone App are you using? This information can be found in the “Support” Tab of your app’s settings. This information may help me to better understand your issue.

In order to ensure that this never happens again, make sure that any time you make a change to your FTP, that you give the app the appropriate amount of time to sync before starting your workout. If you wish, you can also check that the FTP has updated in your Settings, but like I said, this usually happens seamlessly as long as you have an internet connection.

I am happy to help you troubleshoot this issue further in a Private Message to make sure that any and all persisting issues are sorted out. Again, I’m really sorry for the inconvenience and I’m hoping that you’ll give us the chance to make it right :slight_smile:

Cheers,
Bryce

1 Like

Great turnaround and response time!

1 Like

Never ever had anything happen like that. I use iPhone 7 for workouts. On my MacBook Pro I use the Mac app to browse workouts and training plans. Been using both iPhone app and Mac desktop app for months, zero problems. I’ve also used Mac desktop app to run workouts, but I much prefer using my phone.

One possibility… my TrainerRoad account is connected to Garmin Connect. and the only “hmm, how did my ftp update in TR?” incidents were due to ftp updates I made in Garmin Connect. In fact it just happened last Sunday because I forgot to update Garmin after the Monday 17 December ramp test.

Check your ftp history from your web account here: https://www.trainerroad.com/profile/edit/power-weight-history

And if that isn’t the root cause, contact support because something weird happened.

1 Like

So on Wednesday I manually updated my ftp via online that morning. That evening I loaded up my app on my Mac and started doing the workout to realize it hadn’t updated my ftp. I closed out of the app completely and reloaded but it didn’t update. I had to input the number in settings. I assumed it would just drag it from the online version. Will I need to put the number in for both locations each time I manually update my ftp?

Lets say you have TrainerRoad on your Laptop and your iPhone.

If you update your FTP in the the TR app from your iPhone, it will immediately sync with the Web as long as you give it enough time to do so.

Then, the next time you open the TR app on your Laptop, it will sync with the Web and update to the new FTP. You need to give it enough time to carry out this sync, but it will be automatic as long as you have internet connection.

The key is to have a good internet connection as well as giving the app enough time to perform the sync. I’m going to go ahead and try to replicate the issues you are experiencing to see if there is in fact something wrong with the apps themselves.

I just tested this out by changing my FTP from my iPhone. I checked the TrainerRoad Web and the FTP was updated almost immediately. I then opened my TR app on my laptop, and the FTP was also updated there, so it appears that everything is working correctly as long as your internet connection is solid :+1:

I just did the same thing, bumped my ftp via online / web, then launched TrainerRoad app on my MacBook Pro and less than 5 seconds later clicked on Account and my new ftp had synced.

Working here.

I checked my ftp history after posting my question and found that for some reason on the day I changed it nothing occurred, but weirdly on Thursday my ftp went back to the original :thinking:

I don’t really mind if it’s a one off thing, and I’ll likely just double check it before I load up a ride if I input a higher ftp.

Well, it originally hadn’t for me. But I’m glad it worked on yours. I will probably update it again in the future and I will simply double check that it transferred over :slight_smile:

Sometimes computers make life easy, and sometimes not :wink:

3 Likes

If it’s “far to easy” that’s your first clue something is up. You should be able to just look at the power profile of a workout and know what it will feel like. If it feels worse, you might have a issue with nutrition or recovery. If it’s too easy that’s an FTP or trainer set up issue.

Coming back to this after my rant. Wasn’t a brilliant day for me and that didn’t help. So apologies for the blunt replies.

It does look like there is an issue here so I will stay off the Mac Desktop app and just use my iPhone.

As far as having a solid internet connection is concerned - honesty don’t think what was the issue as the desktop Mac is connected to a router (via wired ethernet) with a 50mb internet account.

It looks like the desktop app just pushed its FTP and Weight from when it was last used up to the online account, rather than doing the logical thing and downloading it / checking dates etc

I did another experiment after changing ftp in web app, and confirming it propagated to Mac app. When I reverted to original ftp on web app, the Mac app didn’t update. So in my simple experiment I was able to experience a sync failure, at least while being impatient and only giving it a minute to sync and then a Mac app restart.

1 Like

I’ve been having this issue over the past week. I use TR on my mac at home, but login to the website at work and on my phone ap. I’ve notice it revert my FTP numerous times after a manual adjustment. Shot a note to support this morning - but unclear given the above if there was any solution? Thx

2 Likes

Thanks for reaching out to Support, they’ll be in touch soon and will be able to investigate what is going on here :slight_smile: