Wahoo Elemnt trouble with power meter

Till yesterday, everything worked perfectly on my bike and I had tubeless tires installed by the bikeshop.

Today, Wahoo Element does not connect with the SRAM power meter. This has never happened before. The Element does not have a problem connecting with the SRAM AXS gears… On the SRAM app everything works fine, so I’m guessing the problem is with the Element.

I have updated the Element, activated the power meter a zillion times while trying to make the connection to no avail. After I deleted the power meter from the menu, to set it up as a new sensor, the sensor did not even show up. It’s as if there is zero connection between the Element and the power meter (but the power meter does connect with the SRAM app). Ive also tried doing the above while logging out of the SRAM app.

By now I’m at wits end, as nothing seems to work and Wahoo support isn’t open. I would welcome any ideas on how to fix it.

Sounds like something else is connected and not allowing the head unit. Ensure nothing else is connected to the PM (phone, trainer, iPad, another head unit, etc.). Especially check that no apps are connected to the PM (Sram AXS, Element Apps). Turn off Bluetooth on your phone. Go somewhere outside where it can’t possibly connect to something else.

Ensure battery life on PM. Forget PM on head unit. Try again to find and connect after waking it up.

1 Like

A couple years ago wahoo did an update and after my PM wouldnt connect. It was a problem with their update and they had to release another update to make it work. Maybe it has something to do with the updare?.


The central screw holding the battery spring can come loose. My quarq went intermittent after a crash, did a simple unscrew, wipe and was resolved.

1 Like

It turned out that an app on an iPad was connected to it. I had completely forgotten about that one. Thanks for the advice guys!