Wahoo Elemnt Companion App Not Syncing/Sending Rides to TrainingPeaks

It has worked flawlessly for years but, all of a sudden last week my rides won’t sync to TrainingPeaks. They get uploaded to Strava etc…just not TrainingPeaks.

Both TP and Wahoo Elemnt apps are up to date. I’ve uninstalled and reinstalled both TP and Elemnt Companion app. I’ve re-authorized everything. I’ve tried editing the workout in the Wahoo Elemnt app. Checked Wi-FI…

No matter what I try While in the Wahoo Elemnt app looking at authorized apps TrainingPeaks endlessly says “exporting Workout” while Strava says “exported”.

Maddening. Any help appreciated.

I got this over the weekend. On the same page where you see “exporting workout” you can email the .fit file and manually upload it. Not ideal, but it’s a pretty simple work-around for what should be a temporary issue. :crossed_fingers:

1 Like

Having the same issue, just thought it was me.

1 Like

Same here. I have to go into the Elemnt app and click upload, whereas it used to happen automatically.

Saturday it took 30-45min to synch, Sunday and today was a little better.

The way that uploads and all that stuff works was changed, if issues are being encountered open a support ticket[1] so they can track it.

[1] https://support.wahoofitness.com/hc/en-us/requests/new

So for years iit was automatic. Them some months ago I had to manually upload with a “click” in the Elemnt app as you wrote. Now it simply won’t upload. No cloud upload icon to click on…Strava still automatic so I assume it’s on TrainingPeaks side.

Did you file a support request with TrainingPeaks? They have been pretty quick to reply to my requests.

Is your Elemnt up to date with the most current software? I was having this same problem for weeks, and it was infuriating. Wouldn’t sync my planned workouts via TP anymore either. Then one day, it just fixed itself after a new software update. I had put in a few tickets with Wahoo during this whole process, and none of their suggested fixes had worked, but the update seemed to do the trick for me.

So this morning I had an update for Chrome which I did. Then shortly thereafter I got a notification for a systems update on my Mac which I did. Went back into companion app and made sure automatic upload was on for both Strava and TP.

After the ride this morning the data was sync’d with TP as before (automatic) but, now Strava has be done manually (by manual i mean on the upload page of the ride info on the Elemnt companion app…blue cloud…).

@WindWarrior question for you…IDK why the system update and/or the Chrome update would matter but, perhaps that helped? Any insight appreciated.

TL;DR It’s working again. :thinking:

I thought Wahoo computer sent ride to phone, then Wahoo app sends into cloud and it lands in TrainingPeaks, Strava, etc. so I think it’s just a coincidence that it’s working after your computer updates.

2 Likes

The TrainingPeaks app has been all jacked up lately, not sure if related

1 Like

What’s jacked up? I use TrainingPeaks everyday and haven’t noticed anything unusual or broken.

1 Like

Android? Not seeing that on iPhone. Or on browser.

Yep. Been couple days. Restart, clearing cache etc… no effect

Might be Android “customizations” by Samsung and others. Or something else.

Add me to the list - the iOS app used to automatically upload to TrainingPeaks and now I have to do it manually.

2 Likes