Outside planned workout won’t sync to Wahoo Bolt

For some reason I can’t sync outside workouts to the wahoo bolt. The apps authorised, the workout is set to outside and says ready to be pulled to wahoo…but it won’t come across to the companion element app or the wahoo bolt?

Any ideas as to why this may be?

Everything is up to date software wise. All apps authorised etc?

Contact support@trainerroad.com for best help.

1 Like

Thanks yes done also. Strangely the planned workout appeared this morning on the wahoo bolt. However it wasn’t showing on the app, or when I went to planned workouts on the Wahoo Bolt it wasn’t there either. Then it just disappeared when I started the ride.

I’ll see if support has an answer.

1 Like

@nickelson Did you get this resolved or get an answer from TR? I seem to be having the same issue. I scheduled an outdoor ride tonight for tomorrow, so not sure if it takes some time to populate, but it the ride is ready to be pulled, per TR calendar. I hope it populates by tomorrow morning though.

Thanks…Al

Wahoo should grab workouts 3 days in advance. Check that you’ve authorized TR from within the Wahoo Companion app. Since TR shows it ready to be pulled, if there are no other issues you should just need to open the Wahoo Companion app -> Load a workout -> Click ‘Schedule’ and you should see the upcoming TR workouts listed there.

Without any other issue, you should see it right away. Just the other day I scheduled an outside ride minutes before heading out the door on the bike, so it should be quick.

Thanks for taking the time to respond. I have TR as an authorized app and I followed their instructions to the “T”. I hope it shows up by tomorrow. If not, I will still do a similar ride as directed since it’s one of those slow, low powered endurance rides.

I sent an email to TR. I provide an update.

Hi, no I didn’t. They came back with the simple answer that I didn’t have any rides set to outside. But the reason is that I set them all to inside and only if I know I can do an outside one, for say tomorrow I change it in the calender.

But no, it still won’t sync across?

If they come up with a solution I’ll let you know. But I think it’s a bug software/sync issue somewhere?

I will let you know what they say. They have not responded yet.

Btw, I experienced the same thing where the training ride did not show up on the Companion app, but populated on the Element Bolt head unit. I was able to do the ride, so not sure what happened.

Thanks for the heads up.

Yes I think if you dismissed it when the training plan prompt appeared on the bolt, then afterwards decided to go into the training plans section on the bolt (where the sky/ineos pre-planned sessions are) it doesn’t show. But yet as you said it prompted you when you turned the bolt on…?

I’ve tried to explain this to TR… Will let you know if I get a reply.

Did you complete the ride? If so, how did you upload it to show completed on the TR calendar? I don’t use Garmin Connect and I did not use Strava during the ride, but I think I can hopefully get it to load to Strava via the Bolt to see if I can load it that way.

Hopefully TR can provide some insight on this. I saw a thread dedicated to this subject on using TR outside, but I can’t seem to find it now.

Is this the one you wanted?

I’ll be honest I skipped the training session and did it inside later that day as it was only a short one.

However, earlier in the day when it appeared and I dismissed it I went for a ride with a friend. The ride Uploaded via strava automatically through the bolt, and TR associated the ride to the training plan automatically. It was nothing like the training plan to be honest (harder) but that’s irrelevant really.

I think because I’d set it to an outside workout, it just associated it thinking I’d done it. Which in theory would be correct, if I’d actually hit start to the training session but I didn’t.

Hi Chad, thanks.

I’ve got a wahoo bolt, but use the same process pretty much. I emailed support and spoke to TR about setting certain sessions to outside, particularly the night before by changing the workout in the calender online.

Problem is, it’s then not syncing across to the wahoo app or bolt, so doesn’t show in the planned workouts?

Im pretty computer savvy, so all software is up to date etc. I Followed any instructions but to no avail unfortunately.

Yes. That’s the thread. Thanks. I kept looking for it in the software pages and not the announcement page.

Again, thanks…

Update: I just realized that is the link to the Garmin and not the Wahoo, but I see you provided the correct link below.

1 Like

Ok, for reference of others, here is the Wahoo version.

I’m sure you’ve done this but what helped me is to make sure the filter is set to schedule and swipe down to refresh on the planned workout page.

1 Like

I just tried to sync some workouts to the bolt to experiment and the planned workouts are not showing up in the element app however they show up in the bolt under planned workouts

Thanks, mine doesn’t seem to show in either. And yes tried filtering thanks, nothing just the ineos preplanned sessions on the wahoo bolt and Nothing showing on the phone app.

I still reckon it’s a software bug.

@nickelson I agree that it has to be a hiccup in the process. I spoke with customer support (Nate) and others are having the same issue. I don’t know what’s being done about it, but I told Nate that I am ok as long as it populates to the Bolt and I can see and use it and get all of the prompts, which I have gotten during the outside ride. For me, this is one less step in the process, meaning I don’t have to open the companion app to upload the ride and I am ok with that. I won’t lose any sleep if it doesn’t populate to the companion app.

Sorry to bump an old thread, but thank you very much @2fst4u for this:

I’m sure you’ve done this but what helped me is to make sure the filter is set to schedule and swipe down to refresh on the planned workout page.

This has been driving me insane, that I can never get the TR rides to show up on my Wahoo, including in the app. It’s extremely confusing that the TR workouts only show up in the list if you explicitly select “Schedule”. Once I switch to that I finally see the workout there.

Thanks a million