Outside workouts not pushing to Wahoo ELEMNT?

Just wondering if anyone else is having issues with outdoor workouts not synching with the elemnt app in iOS? I noticed the recent update claimed to have solved a bug relating to this, but it seems I have to deauthorise and reauthorise TR in the wahoo app every time I want to do a workout outside.

I’ve contacted wahoo support about this but not had much luck yet.

3 Likes

Yes it has been happening to me every single time! I thought it was just me.

3 Likes

Same

1 Like

Same. I reached out to support and they said it is a known issue. This happened to me for 2 different reasons - one was making sure I had on in the wahoo app to use cellular data.

But most recently I have found I need to de/reauthorize data syncing in the Wahoo app every time – even what it says TR is authorized. Works until a permanent fix.

4 Likes

Yup, same here for me. I have found the only work around is to deauthorize and re-authorize TR from within the Elemnt app before each ride. Quite annoying!

1 Like

Well, at least there’s some solidarity here! Fingers crossed it gets fixed soon.

Same issue here. Have to deauthorize + reauthorize TR in the Elemnt App, then re-syncs correctly.

1 Like

Happening to me too! Although last night’s workout seamed to load okay. fingers crossed its fixed

Same here

Me too, although on Android rather than iOS. de & re-authorizing solved it.

I have had this issue since June 2021. Support keeps telling me its on their radar. It’s clearly not IMO.

1 Like

Issue still there.

Hmm. I’m assuming that this issue is at the Wahoo end and not the TR end. Is there someone all-knowing from TR who could tell us whether to try TR support as well?

2 Likes

I’ve logged a TR support ticket and recommend others do too. Mine stopped syncing only in the last few weeks. It’s summer here so really annoying as I train mostly outdoors.

TR has supplied a work around that gets the workout syncd.

According to support it’s an issue at Wahoos end.

I’m going to log this with Wahoo as well.

3 Likes

Sounds like it’s on the Wahoo to-do list. Here’s my latest email from support:

Thank you for letting us know about your experience. This is an issue we are aware of and we have opened an internal ticket with our development team to investigate and resolve the problem.

Since we have an open ticket with our development team, all customer service tickets related to the issue (including this one) will be marked as “On-Hold” and merged with the developer ticket to be monitored internally. This process allows us to send automatic notifications to you via email when changes are complete. Full release notes are posted on https://support.wahoofitness.com

Be sure to keep your app and device up-to-date to receive the fix, when available.

We sincerely apologize for any inconvenience and appreciate your patience and support as we strive to serve you better. Please let us know if you have any additional questions or concerns in the meantime.

I think its ok now .

2 Likes

Wish I saw this a few days ago. I ended up deauthorising TR in my Wahoo app then reauthorising. Everything syncs just fine now.

Haven’t had a chance to try it yet but glad it seems to be working. Here’s the most recent message from Wahoo support:

Thank you for your patience while the issue that you reported was being investigated. Our team has reached out to TrainerRoad, and they’ve made some changes on their side to help resolve this error for you.

To refresh the connection, we will need to deauthorize and reauthorize TrainerRoad in the ELEMNT companion app. Please see the below support article which will walk you through these steps.

https://support.wahoofitness.com/hc/en-us/articles/115000495570-My-ELEMNT-workouts-are-no-longer-sharing-to-my-3rd-party-app

1 Like

I’ve gotten access recently to both the Garmin and wahoo API’s (I have an online workout creator and I’m hoping to allow folks to push to head units). Garmin’s API allows to push workouts up, which I’ve been able to do. However, Wahoo only allows pushing completed workouts, there’s no way I am aware of to push planned stuff. My impression is that Wahoo pulls the workouts from TR. Personally think it’s a silly approach

I’m still having this issue. Workout push to Garmin without issue but not to Wahoo element bolt V1. I have completed deauthorizing process and it still does not work. Very frustrating.