Outside rides only partially sync from Fenix 6

Hi All - Here is the bottom line up front: Outside rides from my Fenix 6 are syncing to TR, but they are lacking any duration or elevation information. Duration says “0:00” and it is not factoring into my weekly volume. Below is some more detailed info if anyone else is interested or having a similar issue. Thanks!

So the outside rides I am recording from a Fenix 6 are partially syncing, but I am lacking some pretty important data from the ride when it syncs. Most notably is the elapsed time of the workout! I can see the map in the calendar. It has the route that I rode. It has the same title I gave it and says “Imported from Strava and Garmin” just like every ride before it. The problem is that it says “0:00” for the duration. So I can not “estimate a TSS” or get credit for the time without creating an additional manual workout. The REALLY weird thing is that when I click on the ride to look at details, it shows the accurate duration (although is still lacking elevation info.)

I disconnected and re-authorized and tried to reset everything. The only thing I can attribute it to is that I just got a new Fenix 6 (was using a Fenix5). I have checked all the settings and tried to eliminate operator error. The fact that the rides are making it over to TR makes me think the settings are all good. I am stuck! All this fancy gear and I am having to manually input ride and TSS estimates. Thanks for any help!

Are they showing up properly in connect??

Yep! All the data in connect is there. Transferring to Strava properly as well.

It would be worth firing off an email to support@trainerroad.com then.

Thanks for the reply. I’ve got TR Support looking at it but they have not seen it before. Figured I would throw it out to the masses. I will keep experimenting and try to eliminate the possibility of operator error. That is usually the case with me and technology.

They have seen it before - I’ve on open ticket from my Garmin 245, and there’s a thread here…

Interesting, I generally “manage” my wife’s TR training calendar and noticed the other day she had a single outdoor ride recorded to her account (sync’d via GC) which had a map and no time either. It was recorded on a Fenix 6s Pro with no PM.

I think this is the only ride sync’d from GC recently and probably the only ride she has sync’d with the Fenix 6s Pro.

That is exactly my issue and the thread I was looking for. Thank you!


I sent through files yesterday for investigation, after the thread got a bump!

same issue here using a forerunner 945. aprox. 80% of my outdoor bike ride recordings appear without duration in trainerroad though they are fine in garmin and strava.