Trainer calibration issues

I am having issues with my Wahoo Smart trainer and trainer road. I use the Kickr + TrainerRoad with either my phone or my Mac computer

  1. On Mac - when I try to calibrate the wahoo trainer via the trainer road software it states that this device does not allow calibration whereas it allowed this function 1 month ago. Ok, fine. I’ll try my phone.
  2. iPhone - as soon as I start the spin down with putting pressure and turning the pedals it immediately finishes the calibration whereas one month ago it would take about 30sec to get to the 24mph target.
  3. Appx one month ago (December) the power meter readings were completely off. While in ERG mode the resistance never adjusted to the desired power. Example - warming up I was spinning and the reading was 220w but felt like 80 watts resistance. The desired resistance at the time was 120 watts. It never adjusted the resistance. I solved this issue by updating the firmware to the wahoo kickr trainer.

I feel like my workouts have been all over the map lately in terms of the function of the trainer and RPE (both feeling easy and harder relative to a month ago)

Has anyone else had this issue? What was the fix?

Have you tried the factory spindown?

I’ve had a few spindown issues with my Kickr Core (regular spindowns often don’t work in TR for some reason for me) and making sure it’s only connected to the wahoo phone app and then a factory spindown usually works.

Good luck!!

1 Like