Trainer Spin down in ERG

I don’t normally do a spin down of my Kickr because I use it with powermatch. But I lately decided to try running Zwift at the same time and wanted the power to be close between Zwift and TrainerRoad. I haven’t been able to get the spin down to work if the trainer is set to ERG mode because it doesn’t seem to show any speed. If I switch to Resistance mode I get speed data and can do spin down.
Is this normal or should I reach out to TrainerRoad support?

Side question: Is there a reason you can’t get or don’t want to pair your power meter for lower data in both apps?

As to calibration issues in TR, it might be worth an email to support. Outside of that, I tend to prefer using the native app for calibration of trainers. So I use the Wahoo one for my Kickr. Might be worth a test at least.

I am using Garmin Vector 3 pedals and as far as I know they can only have one Bluetooth connection. I am new to doing this so it’s possible I am doing it wrong. I don’t have any sort of ANT+ dongle for iPad so I have been using vector 3 with power match to kickr and kickr power reading to Zwift.
I will give the wahoo app a try and see if that makes any difference before contacting support.

1 Like

Ok, that makes sense and is what I figured might be the case.

So, worth an email to TR for one, and might as well test a calibration with the Wahoo app in the meantime.

So warmed up Kickr tonight for 10 minutes and then tried spin down using Wahoo app but still no luck. Strange thing is both on wahoo app and TrainerRoad app that while on sensor pages I get speed, cadence and power data but as soon as I try the spin down I get no speed data.
Seems like it may be more of a wahoo problem then a TrainerRoad problem so may contact their support instead of TrainerRoad.

When you are trying the spin down, how many apps do you have open / possibly connected to the Kickr? If more than one, try it with all of the other apps closed except for the one you are trying to do the spin down with.


Same thing happens here with my kickr corona and assioma duos. I need to turn basically unplug all other Bluetooth devices like kickr climb and headwind and unplug, plugin the core and select standard or resistance mode

1 Like

I’ve only had one app open at a time when trying. Also tried with all apps closed using my wahoo head unit and still would t work.

As you note, this is sounding more like a trainer issue with the most recent info.

1 Like

This is a very interesting problem because I have the exact same set up as you have and I have zero issues connecting my Garman three paddles to both TrainerRoad and zwift at the same time. When I do a ride I open up TrainerRoad on my phone I calibrate the pedals, Then I usually do a spin down on the Wahoo and is that spinning down I open up zwift on my Apple TV and itconnects with the pedals

1 Like

Gamrin three pedals

Interesting…maybe I’ll try this again once I sort out some other technical issues I’m having.

So an update on my spin down problem. Contacted wahoo support and they instructed me to do a factory spin down which is supposedly different then the regular one.
Did it today and it seems to have solved the issue.

Unfortunately I have also picked up a vector 3 issue that needs to be resolved next.

1 Like