TR display issue after minimize

Hi there,

I have been having this issue for a while but too lazy to share until now.

Everytime when I minimize TR software, when I tried to reopen the software, the UI will go dark complete, regardless if I am doing a workout or not. I was able to replicate the issue every time.

By minimize, I don’t mean switch to the bar mode at the bottom of the screen, but actually button on the top right corner, or simply click on the icon on the ‘task bar’ on windows. It doesn’t seem like I lose all control when the screen go dark - you can see I can still save the ride or discard it if I want to force quit the software.

I am running TR on my surface pro4. Currently running windows 10 if that is relevant. I wonder if anyone else has experience the same and how could I resolve this?

You can see the images attached below.

1 Like

I’ve had it give me a blank screen too when I un-minimise things but I put it down to my crap computer :smiley:

The issue happens when you have a web browser open too. Occurs on mine as well, a s my laptop is far from crappy.

Yep. I had this. Support tried few things but no luck. Now use legacy app and no problems at all.

This happened to me for the first time a few days ago!

I was watching Youtube in Firefox, with TR minimal screen at the bottom. I hit Win+D (shortcut for desktop - it minimises everything), and when I tried to restore it, TR would be black although the workout would still be progressing.

Eventually I figured out that if I closed Firefox, and then restored the TR window, it would restore.

Nearly made me quit halfway through a workout!

What’s legacy app?

It’s the old version of the Win and Mac app.

2 Likes

I have this issue too. It would freeze trainer road but the progress would still continue. extremely frustrating. using it on an older windows laptop. it would happen if I switch on a google chrome and minimise it using the bottom right hand corner button and it would freeze trainer road and pressing anything on trainer road app would make no difference. I have to use task manager to end the program and restart trainer road.

This all sounds identical. Support believed it was due to old laptop below min spec levels. Used laptop for years no issue but I think recent additions, especially group workouts have pushed up laptop power/spec required.

Now use legacy app and works perfectly. No group workouts but never once used them anyway. Only thing I miss on legacy is the ‘extra stats’ when working out such as current Iterval power and live tss.

Known issue (there is another thread or two about it). The answer is use the legacy app for the foreseeable future. My laptop isn’t new, but by no means outdated. I think it’s more of a bug than a true “performance issue” as I when I run diagnostics I’m not maxed out on CPU nor Memory.

1 Like

Thanks for bringing this up! There have been a few TrainerRoad athletes on Windows who reported something similar, Nonetheless, I think its a good idea to touch base with support to make sure they don’t have any troubleshooting steps that can help isolate and reduce these instances!

You can email them at support@trainerroad.com, or Submit a Request online. They’ll do their best to sort you out! :v:

Thanks for replying! I was thinking if I were alone in this. It hasn’t bothering me enough to be a major issue, but I will definitely get in touch with the support! Cheers!

1 Like

Same thing here – started to email support and never got it finished. Will send that information in. Win10 machine. Just is irritating at 5am when I don’t want to be there in the first place (can you tell how I feel about the trainer right now?) :slight_smile:

1 Like

Want to report back:

I had a zoom call with TR support team and have them record what happened.

Nothing obviously has surfaced. Still debugging it. My gf is also running TR on her mac and never had this issue. I am wondering if it has anything to do with windows version?

I have supplied my laptop spec to the support team and it is definitely up to the job.

Will report back if I hear any update on this. Hopefully it can be resolved!

It’s only been reported on Windows devices, so the team is working actively to isolate what kind of setting, version, or otherwise is triggering the issue! Thanks for hopping on that call and helping us sort this out!

1 Like

Anytime! The goal is to make experience better for all shareholders :slight_smile:

1 Like