Tacx Neo 2 trainer not showing after completed ramp test

Hello. I’ve begun my base workout but completing my ramp test yesterday, and loading up my training calendar. This morning I wanted to do my first workout but the trainer is not being recognised in the app (iOS nor Desktop Mac). I competed the ramp test on iOS yesterday, and this morning download the Mac Desktop app to run from my laptop, I presume this second app ‘instance’ isn’t the cause of the problem, but could it be? The trainer shows up fine on Fulgaz app and broadcasts data as expected. Of course I’ve quit Fulgaz when using trainneroad app/s.

I’ve tried all the usual troubleshooting steps:

  • reset the trainer
  • quit the iOS app, bluetooth off/on, restarted phone etc.
  • quit the desktop app, bluetooth off/on, restarted Mac.

Any ideas?
Thanks in advance.

Make sure that only one device’s Bluetooth is turned on at a time (Mac or iPhone). Secondly, make sure the trainer is plugged in or you are pedaling.

How far is your Mac from the trainer? If not distance, then perhaps reset the Bluetooth module. Hold Shift-Option and click on the Bluetooth icon in the menu item (menu bar top of screen). Go to: Debug > Reset the Bluetooth Module

If you use the Tacx utility from your phone, does the trainer appear okay?

1 Like

Hello. Thanks for your feedback; I tried all those things beforehand, but I have since found the problem which isn’t trainerroad related, but I’ll post here in case someone else has trouble.

The Tacx Neo 2 trainer somehow maintained a Bluetooth connection to my Apple TV even when the Apple TV was switched off. I had to physically unplug the Apple TV from power for a few seconds for the bluetooth connection to drop. Once I did this the trainer showed up in trainer road and I was good to go.

Were you using Zwift or some other app on your AppleTV w/the Neo?

In any case, make sure you force quit whatever app you were using before you put the AppleTV to sleep. That should disconnect the Neo from your AppleTV and prevent this from happening again.

Yes, I was using Fulgaz after my ramp test. I did of course quit the app and as mentioned came back the next day to start my workout, where thew Apple TV had been switched off. The Apple TV still maintained the connection throughout the night somehow. I know the quick fix now :slight_smile: