Average power issue

My bike was in the shop, so I popped down to my old man’s and used his bike and Neo for my TR workout.

I had my Macbook with me, so rather than changing his setup with his Windows machine and ANT+ kit, I just connected the Neo to my Mac via Bluetooth, which worked fine with one exception…

There was no power smoothing. It was jumping every second or so, whereas with my Flux on ANT+ it’s fine.

I haven’t tried my Flux with Bluetooth or the Neo with ANT+ to isolate those as the issue, but I was wondering if I was missing anything (eg Bluetooth doesn’t do power smoothing?).

I’m on 2018.39.0.83144, and have power smoothing set to 8 seconds.

Apologies for the shaky video…


Unfortunately I can’t make out what is going on in your application, however, the Power Smoothing should be present regardless of your pairing method.

8 seconds of smoothing should certainly be enough to smooth out even the most responsive trainer, so there is something that is going a little “wrong” here. I would recommend logging out and back into the application so that the app re-loads its settings. This may resolve the issue.

If this issue continues, and you would like to troubleshoot further, I would recommend reaching out to our Support Team at support@trainerroad.com as they are the experts on this type of thing :slight_smile:


1 Like

I can’t see the video but tacx stuff usually has an issue where Bluetooth has priority over ant+ and it will only connect to a single bt device for control at once. This means if you used the utility on your phone prior to the ride and didn’t close it out properly that utility still has full control and TR can at best listen (though I think it just shouldn’t connect if you use Bluetooth like this).

I shouldn’t imagine that’s the issue, as Bluetooth is a 1-1 connection vs ANT+ which is 1-Many.

So if the Tacx app had control of the Bluetooth connection, my Mac wouldn’t have been able to connect to it.