Saris H3 calibration fails repeatedly

Howdy –

Starting yesterday calibration on my H3 has been consistently failing. When I click on “calibrate” in the app, I immediately get a “The calibration failed unexpectedly. Would you like to try again?”. I click on Retry and it has be pedal to 18mph. After I reach that speed, the green check mark comes out and then it speed slowly goes down to zero. Then I get another failure popup, this time saying “Calibration attempt timed out.” If I try another calibration the same exact thing happens. Restarted my phone and unplugged the H3 to no avail.

This was working without a problem on Thursday. I’m pretty sure the speed it had me target then was 22mph so I think the app changed? Though when I look on the Google app store, it says the TR app updated on 1/14. Not sure when I got the actual update though…

I’m able to perform a calibration in the Saris app without a problem. But it’s kind of a PITA to switch apps whilst in the middle of a ride. Guess I’m lazy that way. Especially since calibration was working for the past 2 months

My firmware is up to date on the H3 (12/18/2018) and Android TR app is 2020.3.0.92026. And this is using Bluetooth on an Samsung S9. Let me know if more info would b helpful.

Anyone else having problems with the TR app on Android with a Saris H3 (connected over Bluetooth)? Or should I fire an email off to the wonderful folks at TR support? Thanks in advance.

I have a similar problem with my H3. It says “calibration failed unexpectedly…”, on both bluetooth and ant+ in the TR app. I can’t get my app to find the trainer either, so I can’t do the calibration there either. I’ve been running power match, so I have not been too worried about it, but I do need to fix this at some point, and I’m not sure how.

Calibrate with rouvy if you cannot get it to work which is odd.

1 Like

This has been a known issue with the saris/cycleops trainers. Use either the rouvy or saris apps to do a calibration. I’ve been using the saris app as it’s much more straightforward than navigating rouvy’s menus.

1 Like

True, however I can’t update my H3 using the Saris app. Yet I can with Rouvy?

  • What happens when you try?

  • Are you using Android or Apple?

  • Have you contacted Saris about the issue?

Can you try over ANT+ instead of BT? My H1 always fails via one of the two (I forget which) but reliably works on the other.

1 Like

Yeah, confirmed.

I emailed TR support and this is a known issue with Bluetooth with Saris trainers. They were able to reproduce in the office but were having trouble coming up with a fix. So, no ETA on solution.

The suggestions I got were to calibrate over ANT+ or use the Saris app to calibrate.

1 Like

I had the same issue when using the PC app. However, I was able to calibtrate using my phone (IOS) app. I contacted customer support and they confirmed there was a bug with the PC app.

1 Like

I always use the Roovy app also.

Saris app to calibrate and update. Works on the iPhone.

1 Like

Saris app on android worked for me.

1 Like

Rouvy app all the way. Tried the Saris app when I first got the H3 in September, and the app just never worked. It was buggy and clunky. Rouvy app works as it should.

The Saris app is far from great, but they have improved stability and function a lot since it was originally introduced.

I had that problem when I first purchased the H3. Turned out that the dropout nuts on the trainer were loose from the factory. Tightened them up and hasn’t failed a calibration since. Worth a check I suppose.

I am having a similar issue with Kinetic Rock and Roll I Control Trainer. I have performed dozens of spin down calibrations on an iPad using the trainer road IOS app, all getting the “timing out” error. Does anyone have any experience dealing with this with Kinetic trainers?